Gentoo Archives: gentoo-accessibility

From: William Hubbs <williamh@g.o>
To: gentoo Accessibility <gentoo-accessibility@l.g.o>, speakup mailing list <speakup@×××××××××××.ca>
Subject: [gentoo-accessibility] speakup on gentoo
Date: Sat, 19 Apr 2008 21:54:10
Message-Id: 20080419215408.GA2732@linux1
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

All,

I am pleased to announce that speakup is now available as a package on
gentoo.  It requires at least gentoo-sources-2.6.25-r1 in order to run.

To install it, do the following:

Make sure you unmask gentoo-sources and speakup, if you haven't already,
by doing this:

echo sys-kernel/gentoo-sources >> /etc/portage/package.keywords
echo app-accessibility/speakup >> /etc/portage/package.keywords

Next, emerge, configure, compile and install the latest version of
gentoo-sources.  Make sure that /usr/src/linux points to the new kernel.
You will not see anything about configuring speakup when you configure
the kernel, but that is normal.

After the kernel is installed, emerge speakup.  This will build speakup
as modules, outside the kernel tree.

In order to have your system start speaking on boot, you need to set up
the synth module in /etc/modules.autoload.d/kernel-2.6 or
/etc/conf.d/modules, depending on the version of baselayout you are
using.

I just committed this a few minutes ago, so it may take some time to go
to the rsync mirrors; I would suggest waiting about 45 minutes after
this message is sent then doing an emerge --sync.

Please test and provide feedback.

Thanks much.

- -- 
William Hubbs
gentoo accessibility team lead
williamh@g.o
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)

iEYEARECAAYFAkgKagAACgkQblQW9DDEZTgGtQCffXfH1m8sugHBUGlmAFsOYSwL
66MAnRD3NvLe6urJoV8m9b/xjDmhkNv6
=xz+n
-----END PGP SIGNATURE-----
-- 
gentoo-accessibility@l.g.o mailing list

Replies

Subject Author
Re: [gentoo-accessibility] speakup on gentoo Robert Grieve <sonofthejedi@×××××××.nz>