Gentoo Archives: gentoo-accessibility

From: William Hubbs <williamh@g.o>
To: gentoo Accessibility <gentoo-accessibility@l.g.o>
Cc: speakup mailing list <speakup@×××××××××××.ca>
Subject: [gentoo-accessibility] speakup and 2.6.37 on gentoo
Date: Tue, 01 Feb 2011 17:02:08
Message-Id: 20110201163056.GA26245@linux1
All,

gentoo-sources-2.6.37 is in our tree. I do not know when it will be
marked stable, but I wanted to go ahead and post a message about the
upgrade process for speakup users.

When you configure a 2.6.37 or newer kernel, you will find speakup in
the staging drivers under device drivers in the menu. Be sure to select
the speakup core and the synthesizer driver(s) you need. They can either
be modules or built in.

Once the new kernel is compiled and installed, you should be able to
boot normally and have speakup start talking.

That is all there is to the upgrade process. If you want to use a kernel
older than 2.6.37, you can keep the app-accessibility/speakup package
installed, since it will continue to work for older kernels. But, if you
are not interested in older kernels, you do not need this package any
longer, so you can unmerge it once you are using 2.6.37 successfully.

Let me know if you have any questions.

---
William Hubbs
gentoo accessibility team lead
williamh@g.o

Replies

Subject Author
Re: [gentoo-accessibility] speakup and 2.6.37 on gentoo Robyn Dawn Hannigan <sonofthejedi@×××××××.nz>