Gentoo Archives: gentoo-admin

From: Ralph Seichter <gentoo-ml@××××××××.org>
To: gentoo-admin@l.g.o
Subject: Re: [gentoo-admin] How to satisfy Portage dependencies with dummy packages (or other methods)?
Date: Wed, 24 Aug 2005 09:42:41
Message-Id: 430C40F2.8030500@sentries.org
In Reply to: Re: [gentoo-admin] How to satisfy Portage dependencies with dummy packages (or other methods)? by Georgi Georgiev
Georgi Georgiev wrote:

 > Put mail-mta/ssmtp-2.60 in package.provided and see if you'll get
 > an upgrade to 2.61 with emerge -pud (or -aud) world.

I just tried it, and ssmtp is not marked for an update when using
"emerge -puD world". Nice. I can even use these settings

   # /etc/portage/profile/package.provided
   mail-mta/postfix-2.2.5

   # /etc/portage/profile/virtuals
   virtual/mta mail-mta/postfix

and emerge does not try to install ssmtp. As I don't provide ssmtp
but my own Postfix 2.2.5 installation, as you correctly observed,
these are the settings I'll use. Thank you, Georgi.

-- 
Mit freundlichen Grüßen / Sincerely
Dipl. Inform. Ralph Seichter

-- 
gentoo-admin@g.o mailing list