Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-admin
Navigation:
Lists: gentoo-admin: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: <gentoo-admin@g.o>
From: "Nerdvana - Steve Walsh" <S.walsh@...>
Subject: RE: Problem with sudo
Date: Thu, 25 Aug 2005 01:07:22 +1000
Marc;

Ownership and permissions look ok. What user are you attempting to run sudo
as? Are they in the wheel group? What entry do you have for the wheel group?

Steve

-----Original Message-----
From: marceluda [mailto:marceluda@...]
Sent: Thursday, 25 August 2005 12:44 AM
To: gentoo-admin@g.o
Subject: Re: [gentoo-admin] Problem with sudo


Here it is:

magi ~ # ls -sail /etc/sudoers
14811 4 -r--r-----  1 root root 1645 Aug 24 10:27 /etc/sudoers


Nerdvana - Steve Walsh wrote:
> marc;
>
> You may have the immutable bit set on sudoers. What is the result of a
>
> ls -sail /etc/sudoers
>
> Regards
>
> Steve
> -----Original Message-----
> From: marceluda [mailto:marceluda@...]
> Sent: Wednesday, 24 August 2005 11:17 PM
> To: gentoo-admin@g.o
> Subject: [gentoo-admin] Problem with sudo
>
>
> Hello, I'm new in the list and I don't know if this is the placefor askin
> about a strange problem
> I'm having.
>
> I finished a clean instalation of gentoo 2005.1 from the CD in a pentium4
> machine.
> I installed sudo (emerge app-admin/sudo) and tryed tu use it but I get the
> following error:
>
> magi ~ # sudo
> sudo: can't open /etc/sudoers: Permission denied
> sendmail: Cannot open mail:25
>
>  From any user, even from root. The file perms are ok:
>
> magi ~ # ls -l /etc/sudoers
> -r--r-----  1 root root 1645 Aug 24 09:41 /etc/sudoers
>
> I used the following USE params in the installation:
>
> CFLAGS="-O2 -march=pentium3"
> CHOST="i686-pc-linux-gnu"
> CXXFLAGS="${CFLAGS}"
> USE="acl bzip2 cdr chroot clamav clamd clanJavaScript dvd dvdr elf
ethereal
>       extensions iconv libclamav maildir md5sum memlimit mpm-worker
>       no-htdocs openntpd openssh openssl qmail rar reiserfs savedconfig
>       screen smp spamassassin sse sysfs vhosts vim-pager virus-scan
>       vpopmail xfs -X -avi -berkdb -bitmap-fonts -emboss -gnome -gtk
>       -gtk2 -ipv6 -kde -mad -mikmod -mp3 -mpeg -oggvorbis -opengl -qt
>       -quicktime -truetype -truetype-fonts -type1-fonts -xmms"
>
> I don't know if one of these USEs can affect the instalation, I think not,
> because sudo only uses:
> [ebuild   R   ] app-admin/sudo-1.6.8_p9  -ldap -offensive +pam -skey 0 kB
>
> Can anybody help me?
>
> marceluda
>
> PS: Sorry for my bad english
> --
> gentoo-admin@g.o mailing list
>
>

--
gentoo-admin@g.o mailing list


-- 
gentoo-admin@g.o mailing list


References:
Re: Problem with sudo
-- marceluda
Navigation:
Lists: gentoo-admin: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Problem with sudo
Next by thread:
Re: Problem with sudo
Previous by date:
Re: Problem with sudo
Next by date:
problem with bridging & xen


Updated Jun 17, 2009

Summary: Archive of the gentoo-admin mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.