Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-admin
Navigation:
Lists: gentoo-admin: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: <gentoo-admin@g.o>
From: Jörg Vorher <info@...>
Subject: Re: Newbie admin - help with mysql
Date: Sun, 1 Oct 2006 15:43:54 +0200


WIR MÖCHTEN VON IHNEN KEINE WEITEREN  EMAILS ODER WERBUNG ERHALTEN



WIR MÖCHTEN VON IHNEN KEINE WEITEREN  EMAILS ODER WERBUNG ERHALTEN
WIR MÖCHTEN VON IHNEN KEINE WEITEREN  EMAILS ODER WERBUNG ERHALTEN

WIR MÖCHTEN VON IHNEN KEINE WEITEREN  EMAILS ODER WERBUNG ERHALTEN










----- Original Message -----
From: "Brian Kroth" <bpkroth@...>
To: <gentoo-admin@g.o>
Sent: Friday, September 22, 2006 4:24 PM
Subject: Re: [gentoo-admin] Newbie admin - help with mysql


>
> Maurice E Johnson wrote:
> >       But wouldn't an attempt to install an app dependent on mysql
> >     potentially succeed eroniously? What I'm trying to see - and
> >     education is always a good thing - is that in order to truely block
> >     mysql, you would need something a bit more complex than an entree in
> >     /etc/portage/package.provided.
> >
> >     Something in addition? like:
> >
> >     equery --nocolor hasuse mysql|awk '{print ">="$1}' >
> >     </etc/portage/package.provided|/etc/portage/package.mask>
> >
> >     to avoid the consequences of basically saying that it's there when
> >     it isn't?
> >
> >     I have read the man page, but it doesn't seem to address the
> >     consequenses down the road for this condition.
>
> I don't think it necessarily should.  By putting something in
> packages.provided you're telling portage that you've taken care of that
> package manually, so it can assume that the dependency has been
> fulfilled.  If at some point down the road your system runs into
> compile or dependency problems you know where to look.
>
> Just to clarify the situation though - you're installing mysql manually,
> and trying to emerge mytop or something else that generally needs mysql
> as a dependency, and you just want it to use your custom built one
> rather than ever emerging portage's stock mysql, correct?
>
> Another option, although probably one that requires more work, would be
> to make an ebuild for your custom built mysql, include it in the local
> overlay and as an added precaution so that you know when a new version
> is out mask all higher versions.  Then "emerge <whatever it is that
> needs mysql>" should work just as if it were using the stock mysql.
> Actually you could probably do the second part in conjunction with
> packages.provided rather than creating an ebuild.
>
> The downside is that whenever your dependent package's requirements
> changed you would most likely get errors about mysql being masked, and
> you'd have to do some conf tweaking again.  The upside is that you'd be
> notified and it wouldn't be emerging mysql.
>
> >
> >
> > ------------------------------------------------------------------------
> >
> > Subject:
> > Re: [gentoo-admin] Newbie admin - help with mysql
> > From:
> > Brian Kroth <bpkroth@...>
> > Date:
> > Thu, 21 Sep 2006 15:15:45 -0500
> > To:
> > gentoo-admin@g.o
> >
> > To:
> > gentoo-admin@g.o
> >
> >
> > Joseph Drake wrote:
> >> I think this will result in failed dependencies.
> >>
> >> Johnson, Maurice E CTR NSWCDL-K74 wrote:
> >>> try
> >>>
> >>> echo "dev-db/mysql" >>/etc/portage/package.mask
> >
> > Exactly, that's why /etc/portage/package.provided was created.  The
> > previous solution was correct.  Namely:
> >
> >  >> You could try something like:
> >  >>
> >  >> echo "dev-db/mysql-4" >> /etc/portage/profile/package.provided
> >
> > "man portage" for more more info.
> >
> >>>
> >>>
> >>> -----Original Message-----
> >>> From: Con Tassios [mailto:ct@...] Sent: Wednesday, September
> >>> 20, 2006 23:20
> >>> To: gentoo-admin@g.o
> >>> Subject: Re: [gentoo-admin] Newbie admin - help with mysql
> >>>
> >>> On Thu, 21 Sep 2006, Easy-Things Info wrote:
> >>>
> >>>
> >>>> How do I tell gentoo that I don't want - under any circumstances
> >>>>
> >>> -
> >>>> emerge to automatically install mysql?
> >>>> I am using binaries and sources straight from mysql.com.
> >>>>
> >>>> I used -mysql in my USE in /etc/make.conf but it doesn't work
> >>>>
> >>>> If I try to emerge -p world it tells me that it will install
> >>>>
> >>> mysql
> >>>> 4.1.x
> >>>>
> >>>
> >>> You could try something like:
> >>>
> >>> echo "dev-db/mysql-4" >> /etc/portage/profile/package.provided
> >>>
> >>> --
> >>> gentoo-admin@g.o mailing list
> >>>
> >>
> >>
>
> --
> gentoo-admin@g.o mailing list
>

-- 
gentoo-admin@g.o mailing list


References:
RE: Newbie admin - help with mysql
-- Johnson, Maurice E CTR NSWCDL-K74
Re: Newbie admin - help with mysql
-- Joseph Drake
Re: Newbie admin - help with mysql
-- Brian Kroth
Re: Newbie admin - help with mysql
-- Maurice E Johnson
Re: Newbie admin - help with mysql
-- Brian Kroth
Navigation:
Lists: gentoo-admin: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Newbie admin - help with mysql
Next by thread:
Re: Newbie admin - help with mysql
Previous by date:
Re: Newbie admin - help with mysql
Next by date:
Re: Newbie admin - help with mysql


Updated Jun 17, 2009

Summary: Archive of the gentoo-admin mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.