Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-alpha
Navigation:
Lists: gentoo-alpha: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-alpha@g.o
From: Andrew Gaylard <ag@...>
Subject: Re: alpha newbie question
Date: Thu, 02 Mar 2006 15:29:05 +0200
Nick Smith wrote:

>>>Surely, all the bootloader needs to know about is /boot?
>>>On my alpha I had no end of trouble trying to use XFS for /,
>>>until I realised that the bootloader only understood ext2.
>>>The solution was to make a separate ext2 partition for /boot,
>>>put the kernels there.
>>>
>>>
>>>      
>>>
>well i just followed the handbook and created sda1 = swap and sda2 = ext3 = /
>
>does this mean im wasting my time on this very slloooow install and
>that its not even going to boot when im finished? or does the boot
>loader see ext3 as well?
>
>also i thought that it saw all my drives, but the bios ( or what alpha
>calls a bios ) see's all 3 9gig drives, but gentoo only see's sda,
>when i went looking in /dev/ it only has the nods for sda and sda1 and
>sda2 for some reason, i found a tips and tricks on the gentoo.org
>website on how to make raid nods, but that didnt seem to work for sdb
>and sdc.  is this normal for alpha to only see the first drive? is
>there a way to make the nods to actually make use of the other drives
>in the system?
>  
>

I don't know if the bootloader can boot off ext3 partitions; I've never
tried.  You'll have to dig into the docs to find out.

To resolve SCSI problems, check if the kernel can see your devices by
looking at the output of "dmesg".  If it shows all devices, then you're
nearly there.  But if not, missing device nodes are the least of your
problems.  And no, it is not normal for only the first drive to be seen;
I have two drives both of which have always shown up in dmesg.

So please post the relevant bits of dmesg output, including the SCSI
controller and all devices.

I'd try to partition your sdb and sdc, make filesystems on them, and
copy lots of data onto them to ensure that the hardware's behaving.
After all, this machine was probably built in the last millenium.
Only if that works would I try to get RAID working (and I'd try just
striping or mirroring sdb and sdc on their own first, before attempting
the / filesystem).

Andrew.
-- 
gentoo-alpha@g.o mailing list


Replies:
Re: alpha newbie question
-- Nick Smith
Re: alpha newbie question
-- Ben de Luca
References:
alpha newbie question
-- Nick Smith
Re: alpha newbie question
-- kloeri
Re: alpha newbie question
-- Andrew Gaylard
Re: alpha newbie question
-- Ben de Luca
Re: alpha newbie question
-- Nick Smith
Navigation:
Lists: gentoo-alpha: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: alpha newbie question
Next by thread:
Re: alpha newbie question
Previous by date:
Re: alpha newbie question
Next by date:
Re: alpha newbie question


Updated Jun 17, 2009

Summary: Archive of the gentoo-alpha mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.