Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-alpha
Navigation:
Lists: gentoo-alpha: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-alpha@g.o
From: Marc Giger <gigerstyle@...>
Subject: Re: problem upgrading the toolchain
Date: Wed, 7 Dec 2005 19:15:08 +0100
I "straced" emerge, perhaps it helps.
That's what I got on the shell:

witch ~ # strace -fF -s1000 -o emerge-trace.txt emerge -b gcc-config
umovestr: Input/output error
sh: 10: No such file or directory
Calculating dependencies ...done!
>>> emerge (1 of 1) sys-devel/gcc-config-1.3.12-r4 to /
umovestr: Input/output error
PANIC: attached pid 6291 exited
umovestr: Input/output error
/usr/lib/portage/bin/ebuild.sh: line 56: 11: No such file or directory
ptrace: umoven: Input/output error
umovestr: Input/output error
>>> md5 files   ;-) gcc-config-2.0.0_beta2.ebuild
>>> md5 files   ;-) gcc-config-1.3.12-r4.ebuild
>>> md5 files   ;-) files/gcc-config-1.3.12
>>> md5 files   ;-) files/wrapper-1.4.7.c
>>> md5 files   ;-) files/digest-gcc-config-2.0.0_beta2
>>> md5 files   ;-) files/digest-gcc-config-1.3.12-r4
umovestr: Input/output error
PANIC: attached pid 6315 exited
umovestr: Input/output error
/usr/lib/portage/bin/ebuild.sh: line 56: 11: No such file or directory
ptrace: umoven: Input/output error
umovestr: Input/output error
umovestr: Input/output error
umovestr: Input/output error
PANIC: attached pid 6338 exited
umovestr: Input/output error
ptrace: umoven: Input/output error
umovestr: Input/output error
umovestr: Input/output error
[preattached child 73 of 6369 in weird state!]
umovestr: Input/output error
PANIC: attached pid 6369 exited
umovestr: Input/output error
ptrace: umoven: Input/output error
umovestr: Input/output error
alpha-unknown-linux-gnu-gcc: Internal error: Segmentation fault (program
as) Please submit a full bug report.
See <URL:http://bugs.gentoo.org/> for instructions.

!!! ERROR: sys-devel/gcc-config-1.3.12-r4 failed.
!!! Function src_compile, Line 25, Exitcode 1
!!! compile wrapper
!!! If you need support, post the topmost build error, NOT this status
message.

The full output of strace is attached.

Thanks

Marc

On Wed, 7 Dec 2005 18:48:02 +0100
Marc Giger <gigerstyle@...> wrote:

> Bryan
> 
> Thank you for your time. I will provide as much information
> as possible to solve these problems.
> 
> witch ~ # cat /proc/cpuinfo
> cpu                     : Alpha
> cpu model               : EV56
> cpu variation           : 7
> cpu revision            : 0
> cpu serial number       :
> system type             : EB164
> system variation        : LX164
> system revision         : 0
> system serial number    :
> cycle frequency [Hz]    : 533172608 est.
> timer frequency [Hz]    : 1024.00
> page size [bytes]       : 8192
> phys. address bits      : 40
> max. addr. space #      : 127
> BogoMIPS                : 1059.80
> kernel unaligned acc    : 190
> (pc=fffffffc00313e20,va=fffffc00243c28ce) user unaligned acc      : 0
> (pc=0,va=0) platform string         : Digital AlphaPC 164LX 533 MHz
> cpus detected           : 1
> L1 Icache               : 8K, 1-way, 32b line
> L1 Dcache               : 8K, 1-way, 32b line
> L2 cache                : 96K, 3-way, 64b line
> L3 cache                : 2048K, 1-way, 64b line
> 
> witch ~ # emerge --info
> Portage 2.0.51.22-r3 (default-linux/alpha/2005.0, gcc-3.4.4,
> glibc-2.3.5-r3, 2.6.12.5 alpha)
> =================================================================
> System uname: 2.6.12.5 alpha EV56 Gentoo Base System version 1.6.13
> ccache version 2.3 [enabled]
> dev-lang/python:     2.2.3-r5, 2.3.5-r2, 2.4.2
> sys-apps/sandbox:    1.2.12
> sys-devel/autoconf:  2.13, 2.59-r6
> sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
> sys-devel/binutils:  2.15.92.0.2-r10
> sys-devel/libtool:   1.5.20
> virtual/os-headers:  2.6.11-r2
> ACCEPT_KEYWORDS="alpha"
> AUTOCLEAN="yes"
> CBUILD="alpha-unknown-linux-gnu"
> CFLAGS="-mcpu=ev56 -O3 -pipe"
> CHOST="alpha-unknown-linux-gnu"
> CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
> /usr/share/config /var/qmail/control" CONFIG_PROTECT_MASK="/etc/gconf
> /etc/terminfo /etc/env.d" CXXFLAGS="-mcpu=ev56 -O3 -pipe"
> DISTDIR="/usr/portage/distfiles"
> FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
> GENTOO_MIRRORS="ftp://sunsite.cnlab-switch.ch/mirror/gentoo
> http://gentoo.oregonstate.edu
> http://www.ibiblio.org/pub/Linux/distributions/gentoo"
> PKGDIR="/usr/portage/packages"
> PORTAGE_TMPDIR="/var/tmp"
> PORTDIR="/usr/portage"
> SYNC="rsync://rsync.gentoo.org/gentoo-portage"
> USE="alpha acl apache apache2 arts berkdb bitmap-fonts bzip2 crypt
> cups eds encode ev56 expat font-server foomaticdb fortran gd gdbm gif
> gmp gpm gstreamer gtk2 imlib jikes jpeg libg++ libwww mad mhash mikmod
> motif mp3 mpeg mysql ncurses nls no-htdocs nptl ogg oggvorbis opengl
> oss pam pcre pdflib perl php png postgres python quicktime readline
> sdl slang snmp spell ssl tcpd tiff truetype-fonts type1-fonts vorbis
> xmms xv zlib userland_GNU kernel_linux elibc_glibc" Unset:  ASFLAGS,
> CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTDIR_OVERLAY
> 
> As you can see I use gcc-3.4.4. This was a test if it would made
> any difference. It did also not work with gcc-3.3.x.
> Also I rebuilt portage, python etc (with the new glibc) with no
> success.
> 
> Please ask if you need more infos. I've set up a chroot-env to
> for testing purposes.
> 
> Thanks
> 
> Marc
> 
> 
> On Wed, 7 Dec 2005 11:20:49 +0100
> Bryan Østergaard <kloeri@g.o> wrote:
> 
> > Please don't file a duplicate bug about this problem as we're well
> > aware of the existing bug. The big problem is that we don't seem to
> > be able to reproduce the bug as everything seems fine in our testing
> > using glibc-2.3.5*.
> > 
> > At least 3 Gentoo developers (myself included) have tried to
> > reproduce it without any luck which makes it quite hard to fix.
> > 
> > So what I'd like is a bit more information about the machines this
> > problem happens on. Model of the box, glibc version, kernel version
> > and patchset and output from emerge --info.
> > 
> > Please add all this info to bug 100259 or send it to this list or me
> > directly at kloeri@g.o and I'll see if I can find some
> > pattern to this. Hopefully this will give me some much needed clue
> > about this problem.
> > 
> > Regards,
> > Bryan Østergaard
> > 
> > On Tue, Dec 06, 2005 at 07:39:53PM -0800, Jeff Donsbach wrote:
> > > Thanks, Marc,
> > > 
> > > I guess it's a good thing I didn't build with
> > > USE="-nptlonly" then, huh? ;-)
> > > 
> > > Should I file a duplicate bug in bugzilla (if it would
> > > help)?
> > > 
> > > So, is there some kind of catch 22 going on here?
> > > Weren't there some reports of problems with
> > > linuxthreads in glibc on Alpha?
> > > 
> > > Jeff D
> > > 
> > > --- Marc Giger <gigerstyle@...> wrote:
> > > 
> > > > Hi,
> > > > 
> > > > I reported the same problem to bugzilla...
> > > > http://bugs.gentoo.org/show_bug.cgi?id=100259#c36
> > > > (Perhaps it finds more attention here...)
> > > > 
> > > > It seems it has to do with the current state of ntpl
> > > > on
> > > > alphas.
> > > > 
> > > > If you set LD_ASSUME_KERNEL=2.4.1 and therefore
> > > > force
> > > > to use linuxthreads, emerge works again.
> > > > But I don't know if it really is nptl's fault. I can
> > > > manually
> > > > compile everything with the same parameters as
> > > > portage does. So a portage (sandbox?) fault is also
> > > > possible.
> > > > 
> > > > Marc
> > > > 
> > > > 
> > > > On Tue, 6 Dec 2005 10:45:57 -0800 (PST)
> > > > Jeff Donsbach <jeff_donsbach@...> wrote:
> > > > 
> > > > > 
> > > > > Good point, Nils. Perhaps "5" is the configure.log
> > > > I
> > > > > included? I don't know.I'll try that tonight (the
> > > > > Miata is at home).
> > > > > 
> > > > > Jeff D
> > > > > 
> > > > > --- "Nils o. Janus" <NoJ@...> wrote:
> > > > > 
> > > > > > Hi Jeff,
> > > > > > 
> > > > > > > configure:1892: checking whether the C
> > > > compiler
> > > > > > > (/usr/bin/gcc -mieee -mcpu=ev56 -pipe -O2 )
> > > > works
> > > > > > > configure:1908: /usr/bin/gcc -o conftest
> > > > -mieee
> > > > > > > -mcpu=ev56 -pipe -O2   conftest.c  1>&5
> > > > > > 						 ^^^^
> > > > > > what perplexes me is that stdout is redirecting
> > > > to
> > > > > > the filedescriptor 5
> > > > > > which is not a standardized one.
> > > > > > Does that filedescriptor ( /dev/fd/5 ) exist?
> > > > > > This may be the reason why compiling without
> > > > > > redirecting the output, like
> > > > > > you already tried, works fine.
> > > > > > 
> > > > > > Try passing the 1>&5 to the call of gcc too and
> > > > > > check wether it segfaults  
> > > > > > again.
> > > > > > 
> > > > > > On a DS20e, gcc just throws a "Bad file
> > > > descriptor"
> > > > > > error without  
> > > > > > segfaulting.
> > > > > > 
> > > > > > HTH,
> > > > > > 
> > > > > > greetings
> > > > > > Nils
> > > > > > -- 
> > > > > > gentoo-alpha@g.o mailing list
> > > > > > 
> > > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > 		
> > > > > __________________________________________ 
> > > > > Yahoo! DSL – Something to write home about. 
> > > > > Just $16.99/mo. or less. 
> > > > > dsl.yahoo.com 
> > > > > 
> > > > > -- 
> > > > > gentoo-alpha@g.o mailing list
> > > > > 
> > > > 
> > > > -- 
> > > > gentoo-alpha@g.o mailing list
> > > > 
> > > > 
> > > 
> > > 
> > > __________________________________________________
> > > Do You Yahoo!?
> > > Tired of spam?  Yahoo! Mail has the best spam protection around 
> > > http://mail.yahoo.com 
> > > -- 
> > > gentoo-alpha@g.o mailing list
> > > 
> > > 
> > -- 
> > gentoo-alpha@g.o mailing list
> > 
> 
> -- 
> gentoo-alpha@g.o mailing list
> 
Attachment:
emerge-trace.txt.gzip (Binary data)
Replies:
Re: problem upgrading the toolchain
-- Marc Giger
References:
Re: problem upgrading the toolchain
-- Marc Giger
Re: problem upgrading the toolchain
-- Jeff Donsbach
Re: problem upgrading the toolchain
-- Bryan Østergaard
Re: problem upgrading the toolchain
-- Marc Giger
Navigation:
Lists: gentoo-alpha: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: problem upgrading the toolchain
Next by thread:
Re: problem upgrading the toolchain
Previous by date:
Re: problem upgrading the toolchain
Next by date:
Alpha status Dec 2005


Updated Jun 17, 2009

Summary: Archive of the gentoo-alpha mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.