Gentoo Archives: gentoo-alt

From: Fabian Groffen <grobian@g.o>
To: gentoo-alt@l.g.o
Subject: Re: [gentoo-alt] [PREFIX] Problem compiling libperl on Solaris 11
Date: Sat, 31 May 2008 12:17:23
Message-Id: 20080531121631.GK9590@gentoo.org
In Reply to: Re: [gentoo-alt] [PREFIX] Problem compiling libperl on Solaris 11 by Fabian Groffen
On 29-05-2008 15:17:54 +0200, Fabian Groffen wrote:
> Instead, I get this error on OpenSolaris: > > In file included from perl.h:1195, > from miniperlmain.c:36: > /usr/include/sys/mode.h:49: error: array type has incomplete element type > > weird enough, on Solaris 10 this header effectively contains the same.
OpenSolaris guys here at LinuxTag helped me to fix this issue, I now have the same, as the original reporter, and it seems to be due to an ultra-uglyness of Perl. -- Fabian Groffen Gentoo on a different level -- gentoo-alt@l.g.o mailing list