Gentoo Archives: gentoo-alt

From: Greg Trigg <trigggl@×××××.com>
To: gentoo-alt@l.g.o
Subject: Re: [gentoo-alt] [prefix] bootstrap on AIX with prefix-launcher: currently broken
Date: Wed, 25 Jun 2008 11:15:45
Message-Id: 486228E0.8080605@yahoo.com
In Reply to: Re: [gentoo-alt] [prefix] bootstrap on AIX with prefix-launcher: currently broken by Greg Trigg
Greg Trigg wrote:
> Fabian Groffen wrote: >> On 24-06-2008 15:48:32 -0500, Greg wrote: >>> creating "sh" environment ..... done >>> creating "csh" environment ..... done >>> full cleaning make >>> rm -rf >>> /usr/local/prefix-launcher-1.2/buildroot/make/ibm_slow.powerpc-ibm-aix5.2.0.0 >>> >>> rm -rf /usr/local/prefix-launcher-1.2/buildroot/make/make-3.81 >>> fetching portage >>> downloading prefix-portage-2.2.00.8280.tar.bz2 >>> try download from http://distfiles.gentoo.org/distfiles >>> http://distfiles.gentoo.org/distfiles/prefix-portage-2.2.00.8280.tar.bz2: >>> >>> 19:41:59 ERROR 404: Not Found. >>> try download from http://dev.gentoo.org/~grobian/distfiles >>> http://dev.gentoo.org/%7Egrobian/distfiles/prefix-portage-2.2.00.8280.tar.bz2: >>> >>> 19:41:59 ERROR 404: Not Found. >>> make: *** >>> [/usr/local/prefix-launcher-1.2/buildroot/portage/portage.fetched] >>> Error 1 >> >> Means you got pretty far, but are bitten by me having to clean out my >> distfiles dir regularly... :( Maybe you can find the number somewhere >> and increase it to 2.2.00.10770 (yep some 2000 revisions further along >> the way :) ) >> > Well, I edited the portage.build file to get 2.2.00.10770 and it > installed with > no problems. Now, on to the bootstrap.
That didn't last long. What's going on here? greg:~$ /usr/local/prefix-launcher-1.2/powerpc-ibm-aix5.2.0.0/bin/eprefix-bootstrap --eprefix=/home/greg/gentoo using EPREFIX=/home/greg/gentoo *** doing stage: tree + /usr/local/prefix-launcher-1.2/powerpc-ibm-aix5.2.0.0/bin/bash /home/greg/gentoo/bootstrap-prefix.sh /home/greg/gentoo tree /home/greg/gentoo/bootstrap-prefix.sh: line 149: syntax error near unexpected token `"Setting up portdir"' /home/greg/gentoo/bootstrap-prefix.sh: line 149: ` einfo "Setting up portdir"' failed stage was: tree Greg Trigg Jacksonville, AR -- gentoo-alt@l.g.o mailing list

Replies