Gentoo Archives: gentoo-alt

From: "Tamás Gérczei" <gerczei.tamas@×××××.com>
To: gentoo-alt@l.g.o
Subject: Re: [gentoo-alt] util-linux in a Solaris x86 prefix - can't emerge - doesn't compile + one minor ebuild-level issue to maybe fix
Date: Sat, 09 Jul 2011 11:28:27
Message-Id: CADUGxUSz7tXqo48KaenOMTYeg3Urn2kn79W6Sy-JzyEY84qqWg@mail.gmail.com
In Reply to: Re: [gentoo-alt] util-linux in a Solaris x86 prefix - can't emerge - doesn't compile + one minor ebuild-level issue to maybe fix by Fabian Groffen
Hi Fabian,

Well. That I have tried doing by numerous methods to no avail - and
today I seem to have found the perseverance to build /usr/bin/script
off the misc-utils tree of util-linux hacking all the includes and
headers across the platforms... It even works, more or less, but it
does fail - something just isn't right there concerning the outputs.
BUT: I found ttyrec which, though, won't emerge in the prefix from the
ebuild provided, does compile (and even run and record) fine from the
vanilla source on Solaris 10 - and does therefore solve my problem,
rendering util-linux useless for the purpose I sought.

Many thanks for your advice!
Tamas

On Wed, Jun 29, 2011 at 9:57 AM, Fabian Groffen <grobian@g.o> wrote:
> Hi Tamás, > > On 28-06-2011 20:17:40 +0200, Tamás Gérczei wrote: >> I'm having a problem emerging sys-apps/util-linux in my prefix in a Solaris >> 10 x86 container and I need Your help. > > I thought I fixed the latest version with upstream ... :/ > >> ../../../shlibs/blkid/src/.libs/libblkid.so: undefined reference to >> `strnlen' > > This is the culprit, no such function exists on Solaris. > > util-linux isn't pretty much very non-Linux-friendly.  If you're just > interested in that one script, I'd try to focus on that one, and not to > compile the entire suite of linux utils that you probably don't need. > > > -- > Fabian Groffen > Gentoo on a different level > >