Gentoo Archives: gentoo-alt

From: Benda Xu <heroxbd@×××××.com>
To: gentoo-alt@l.g.o
Subject: Re: [gentoo-alt] Re: emerge gcc 4.4.x/4.5.x fails on CentOS 5.5
Date: Sat, 26 Nov 2011 18:41:42
Message-Id: CAMWv3tFjZBcCd3DZ9L+HGBrM2-1Tnur9iJRA19oMoPE2GgCUMQ@mail.gmail.com
In Reply to: [gentoo-alt] Re: emerge gcc 4.4.x/4.5.x fails on CentOS 5.5 by Moritz Schlarb
Hi,

Just to narrow things down.

   env GENTOO_PATCH_EXCLUDE=10_all_gcc-default-fortify-source.patch emerge
=gcc-4.5*

on CentOS 5 works, this is the point USE=vanilla actually do the click.

that patch is for tuning on -D_FORTIFY_SOURCE=2 by default for C, C++,
ObjC, ObjC++, which is mostly for hardening the system. I guess we can
disable it on certain systems.

BTW, One strange thing is that USE=-fortran emerge =gcc-4.5* works too.

Yours,
Benda

On Sat, Sep 24, 2011 at 10:57 PM, Moritz Schlarb <mail@××××××××××××××.de>wrote:

> > It worked! (Compiling it.) > I will continue with the alt-prefix handbook and report, if I experience > breakages now. >
-- XU Benda Research Center for Neutrino Science Tohoku University JAPAN http://www.awa.tohoku.ac.jp/~benda