Gentoo Archives: gentoo-alt

From: Fabian Groffen <grobian@g.o>
To: gentoo-alt@l.g.o
Subject: Re: [gentoo-alt] Emerging gcc-4.2.3 fails on amd64-linux
Date: Tue, 27 May 2008 12:30:12
Message-Id: 20080527123011.GD4362@gentoo.org
In Reply to: Re: [gentoo-alt] Emerging gcc-4.2.3 fails on amd64-linux by Stefan Hoelldampf
On 27-05-2008 14:25:22 +0200, Stefan Hoelldampf wrote:
> On Tue, May 27, 2008 10:41, Fabian Groffen wrote: > > First: > > - what is your current compiler > > - what gcc-config do you have installed > > - what profile do you use > > - which USE-flags for gcc do you use > > During Bootstrap: > > $ which gcc > /usr/bin/gcc > > $ rpm -qf /usr/bin/gcc > gcc-3.4.6-9 # RHEL4 system compiler
I assume RHEL is a multilib system, is it?
> $ emerge -p gcc-config > [ebuild R ] sys-devel/gcc-config-1.4.0-r04.3
Can you list ${EPREFIX}/lib/libgcc_s* please? Multilib indeed seems to be the problem, but the question is why it finds the wrong lib. This can also be related to the linker (binutils) looking in wrong paths or something. -- Fabian Groffen Gentoo on a different level -- gentoo-alt@l.g.o mailing list

Replies

Subject Author
Re: [gentoo-alt] Emerging gcc-4.2.3 fails on amd64-linux Stefan Hoelldampf <stefan@××××××××××.net>
Re: [gentoo-alt] Emerging gcc-4.2.3 fails on amd64-linux Stefan Hoelldampf <stefan@××××××××××.net>