Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-alt
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-alt@g.o
From: Asfand Qazi <aq2@...>
Subject: Have to make a change to the ebuild every time I build Chromium - am I doing something wrong?
Date: Wed, 20 Jul 2011 12:48:28 +0100
Hi,

I have to always edit the Chromium ebuild to make them work on my 
system, or else I get the following error:


 >>> Install chromium-14.0.825.0 into 
/var/tmp/gentoo/var/tmp/portage/www-client/chromium-14.0.825.0/image/var/tmp/gentoo/ 
category www-client
/var/tmp/gentoo/var/tmp/portage/www-client/chromium-14.0.825.0/temp/environment: 
line 6581: 
MimeType=text/html;text/xml;application/xhtml+xml;x-scheme-handler/http;x-scheme-handler/https;\nStartupWMClass=chromium-browser: 
No such file or directory
sed: can't read 
/var/tmp/gentoo/var/tmp/portage/www-client/chromium-14.0.825.0/image//usr/share/applications/*.desktop: 
No such file or directory


I have to apply the following patch every time to it to make it work:

--- 
/var/tmp/gentoo/usr/portage/www-client/chromium/chromium-14.0.825.0.ebuild 
  2011-07-20 10:32:48.000000000 +0100
+++ 
/var/tmp/gentoo/usr/local/portage/www-client/chromium/chromium-14.0.825.0.ebuild 
    2011-07-20 11:08:10.000000000 +0100
@@ -377,7 +377,7 @@
         make_desktop_entry chromium-browser "Chromium" chromium-browser \
                 "Network;WebBrowser"
                 "MimeType=${mime_types}\nStartupWMClass=chromium-browser"
-       sed -e "/^Exec/s/$/ %U/" -i 
"${D}"/usr/share/applications/*.desktop || die
+       sed -e "/^Exec/s/$/ %U/" -i 
"${ED}"/usr/share/applications/*.desktop || die

         # Install GNOME default application entry (bug #303100).
         if use gnome; then


Excuse me for the line-wrapping.

I've already opened a ticket about this ( 
https://bugs.gentoo.org/show_bug.cgi?id=367651  ), can anyone tell me if 
I'm doing something wrong to have to keep doing this?

Thanks

-- 
Regards,
       Asfand Qazi
       Team 87 HTGT
       Wellcome Trust Sanger Institute


-- 
 The Wellcome Trust Sanger Institute is operated by Genome Research 
 Limited, a charity registered in England with number 1021457 and a 
 company registered in England with number 2742969, whose registered 
 office is 215 Euston Road, London, NW1 2BE. 


Replies:
Re: Have to make a change to the ebuild every time I build Chromium - am I doing something wrong?
-- Fabian Groffen
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Feature request for portage-prefix
Next by thread:
Re: Have to make a change to the ebuild every time I build Chromium - am I doing something wrong?
Previous by date:
Re: Feature request for portage-prefix
Next by date:
Re: Have to make a change to the ebuild every time I build Chromium - am I doing something wrong?


Updated Jun 18, 2012

Summary: Archive of the gentoo-alt mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.