Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-alt
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-alt@g.o
From: Peter Ansell <ansell.peter@...>
Subject: Re: Xcode 4.3 no longer installs the command line tools by default
Date: Fri, 2 Mar 2012 16:22:32 +1000
You can download the command line tools separately now, avoiding XCode
altogether apparently if you don't want to use it (or you don't want
anything to do with App Store). [1]

Peter

[1] http://kennethreitz.com/xcode-gcc-and-homebrew.html

On 2 March 2012 15:42, Charles Davis <cdavis@...> wrote:
> Hi,
>
> I've read the archives, and I've noticed that some of you who have upgraded to/started out with Xcode 4.3 are complaining about the lack of a /usr/include directory.
>
> This is because Xcode is now distributed on the App Store, and therefore has to be distributed as a self-contained bundle. For this reason, the command line tools aren't installed by default. If you want to install them, try these steps. In Xcode:
>
> 1. Open the Preferences window (App menu->Preferences, or Cmd-,).
> 2. Select the "Downloads" pane.
> 3. On this pane, select the "Components" tab.
> 4. In the list of components, you should see "Command Line Tools". Click its "Install" button on the right side.
>
> That should do it. (After Xcode finishes downloading the disk image, of course.)
>
> (For you early adopters out there, this also works with Xcode 4.4.)
>
> Chip
>
>


References:
Xcode 4.3 no longer installs the command line tools by default
-- Charles Davis
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Xcode 4.3 no longer installs the command line tools by default
Next by thread:
Lion and vers_string
Previous by date:
Xcode 4.3 no longer installs the command line tools by default
Next by date:
Re: dev-lang/php-5.4.0_rc7 with apache2 flag does not build libphp5.dylib


Updated Jun 18, 2012

Summary: Archive of the gentoo-alt mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.