Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-alt
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-alt@g.o
From: Aaron Wilson <tallest@...>
Subject: Re: [prefix] emerge fails with "IndexError: list index out of range"
Date: Wed, 11 Jun 2008 14:57:25 -0600
OK. make.conf exists, but make.profile is a broken link, $EPREFIX/usr/ 
portage/profiles/default-prefix/ does not exist. How can I go about  
updating Portage? Can I get it from the overlay snapshot?

Thanks,
Aaron



On Jun 11, 2008, at 11:44 AM, Fabian Groffen wrote:

> On 11-06-2008 11:22:19 -0600, Aaron Wilson wrote:
>>  File "/Users/wilson/Library/Gentoo/usr/lib/portage/pym/portage/sets/
>> profiles.py", line 17, in __init__
>>    self.description = "System packages for profile %s" %
>> self._profile_paths[-1]
>> IndexError: list index out of range
>>
>> I don't know if the problem existed before the sync as I hadn't  
>> touched
>> portage in a month or so. Any help would be greatly appreciated.
>
> Check your $EPREFIX/etc/make.profile and make sure
> $EPREFIX/etc/make.conf exists.  You seem to run an older Portage that
> has problems with those missing or broken.
>
>
> -- 
> Fabian Groffen
> Gentoo on a different level
> -- 
> gentoo-alt@g.o mailing list
>

-- 
gentoo-alt@g.o mailing list


Replies:
Re: [prefix] emerge fails with "IndexError: list index out of range"
-- Fabian Groffen
References:
[prefix] emerge fails with "IndexError: list index out of range"
-- Aaron Wilson
Re: [prefix] emerge fails with "IndexError: list index out of range"
-- Fabian Groffen
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: [prefix] emerge fails with "IndexError: list index out of range"
Next by thread:
Re: [prefix] emerge fails with "IndexError: list index out of range"
Previous by date:
Re: [prefix] emerge fails with "IndexError: list index out of range"
Next by date:
Re: [prefix] emerge fails with "IndexError: list index out of range"


Updated Jun 17, 2009

Summary: Archive of the gentoo-alt mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.