Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-alt
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-alt@g.o
From: Aaron Wilson <tallest@...>
Subject: [prefix] emerge fails with "IndexError: list index out of range"
Date: Wed, 11 Jun 2008 11:22:19 -0600
I hadn't updated portage in a while, I had to remove the SYNC= line in  
make.conf. At the very end of the sync I received an error which is  
now given every time emerge is run:

$ emerge --help
Traceback (most recent call last):
   File "/Users/wilson/Library/Gentoo/usr/bin/emerge", line 20, in  
<module>
     retval = _emerge.emerge_main()
   File "/Users/wilson/Library/Gentoo/usr/lib/portage/pym/_emerge/ 
__init__.py", line 7906, in emerge_main
     settings, trees, mtimedb = load_emerge_config()
   File "/Users/wilson/Library/Gentoo/usr/lib/portage/pym/_emerge/ 
__init__.py", line 7789, in load_emerge_config
     root_trees["root_config"] = RootConfig(root_trees, setconfig)
   File "/Users/wilson/Library/Gentoo/usr/lib/portage/pym/_emerge/ 
__init__.py", line 752, in __init__
     self.sets = self.setconfig.getSets()
   File "/Users/wilson/Library/Gentoo/usr/lib/portage/pym/portage/sets/ 
__init__.py", line 86, in getSets
     self._parse()
   File "/Users/wilson/Library/Gentoo/usr/lib/portage/pym/portage/sets/ 
__init__.py", line 76, in _parse
     self.psets[setname] = setclass.singleBuilder(optdict,  
self.settings, self.trees)
   File "/Users/wilson/Library/Gentoo/usr/lib/portage/pym/portage/sets/ 
profiles.py", line 25, in singleBuilder
     return PackagesSystemSet(settings.profiles)
   File "/Users/wilson/Library/Gentoo/usr/lib/portage/pym/portage/sets/ 
profiles.py", line 17, in __init__
     self.description = "System packages for profile %s" %  
self._profile_paths[-1]
IndexError: list index out of range

I don't know if the problem existed before the sync as I hadn't  
touched portage in a month or so. Any help would be greatly appreciated.

Thanks,
Aaron

P.S. I'm running OS X 10.5.3 on a MacBook Pro Core Duo. 
-- 
gentoo-alt@g.o mailing list


Replies:
Re: [prefix] emerge fails with "IndexError: list index out of range"
-- Fabian Groffen
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
can't emerge app-arch/rpm
Next by thread:
Re: [prefix] emerge fails with "IndexError: list index out of range"
Previous by date:
Re: Recent problem with prefix X applications
Next by date:
Re: [prefix] emerge fails with "IndexError: list index out of range"


Updated Jun 17, 2009

Summary: Archive of the gentoo-alt mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.