Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-alt
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-alt@g.o
From: Perry Smith <pedzsan@...>
Subject: Re: Patch for openssl config script -- but not really
Date: Thu, 23 Dec 2010 08:08:28 -0600
On Dec 23, 2010, at 12:45 AM, Michael Haubenwallner wrote:

> 
> On 12/23/10 01:37, Perry Smith wrote:
>> When my bootstrap process was trying to build openssl-1.0.0c, I got stuck at:
>> 
>> WARNING! If you wish to build 64-bit kit, then you have to
>>        invoke './Configure aix64-cc' *manually*.
>>        You have ~5 seconds to press Ctrl-C to abort
>> 
>> The tty was set with -icanon but I believe the problem is the config script says '#! /bin/sh'.
>> On AIX, /bin/sh is actually ksh and ksh mucks with the tty settings between commands.
> 
> I've not seen such problems since I do </dev/null.
> Does it help to redirect stdin from /dev/null for you too?

I'm not sure when you are suggesting to do the redirect.  It would cause the stty to fail and the read 
would return immediately so it would avoid hanging forever.

I've never seen this before (a configure script that pauses or expects input).  Given that Portage is a 'batch' type
concept, maybe the redirect should be part of Portage.

> 
>> I changed it to use /bin/bsh directly (see below).
>> This could work but I'm a Gentoo Portage Prefix moron so when I started the bootstrap back up,
>> it re-fetched the openssl package and spoiled my fun.
>> I ended up gently killing the youngest copy of sh from another window and that caused things to get rolling again.
>> This may be something to do with my ksh set up too.
>> I don't use ksh but I might have it set so it defaults to emacs mode rather than vi mode.
>> In any case, the script needs to avoid using ksh (on AIX at least).
> 
> Anyway, nice hint, thank you!

I passed this up to the openssl guys too (if I get through their mailer).





Replies:
Re: Patch for openssl config script -- but not really
-- Fabian Groffen
References:
Patch for openssl config script -- but not really
-- Perry Smith
Re: Patch for openssl config script -- but not really
-- Michael Haubenwallner
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Patch for openssl config script -- but not really
Next by thread:
Re: Patch for openssl config script -- but not really
Previous by date:
Re: prefix installer, AIX 5.3 gcc failed to build
Next by date:
Re: Patch for openssl config script -- but not really


Updated Jun 18, 2012

Summary: Archive of the gentoo-alt mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.