Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-alt
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-alt <gentoo-alt@g.o>
From: Michael Weiser <michael@...>
Subject: prefix X11 clients hang on Mac OS X 10.6
Date: Fri, 24 Feb 2012 15:11:38 +0100
Hi there,

does anyone else have problems with X11 clients in current prefix on Mac
OS X 10.6?  For about a month all my X11 clients hang when trying to
connect to either the Snow Leopard X11.app or current XQuartz. When I
compile against the system's X11 libraries, everything works fine. So I
suspect, the X11 libs in my prefix are either too new or broken somehow.
Is that possible?

I've emerge -ateND world 'ed multiple times to eliminate
versioning/linking inconsistencies or abi incompatibility as culprits.
No change.

Even xset q hangs. top shows it hoging a CPU core at 100%. Attaching to
the process with dtruss shows an endless loop of 

select(0x4, 0xBFFFE0C0, 0xBFFFE040, 0x0, 0x0)		 = 1 0
recvfrom(0x3, 0x801A58, 0x1000)		 = -1 Err#35

Any help would be greatly appreciated.
-- 
Thanks,
Micha


Replies:
Re: prefix X11 clients hang on Mac OS X 10.6
-- Johan Hattne
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[PREFIX] Solaris && GNU ld 2.22
Next by thread:
Re: prefix X11 clients hang on Mac OS X 10.6
Previous by date:
[PREFIX] Solaris && GNU ld 2.22
Next by date:
Re: prefix X11 clients hang on Mac OS X 10.6


Updated Jun 18, 2012

Summary: Archive of the gentoo-alt mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.