Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-alt
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-alt@g.o
From: Moritz Schlarb <mail@...>
Subject: Building python fails on SLES10.1 (python-2.7.2)
Date: Sat, 24 Sep 2011 16:58:25 +0200
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi!

On SLES 10.1 (glibc-2.4), building Python fails because the modules
crypt and nis cannot be built.
I worked around this by editing the ebuild to exclude these from
building, hoping that they were not needed for any critical
functionality, but maybe there's some other things that can be done!


I get this at the end:

Python build finished, but the necessary bits to build these modules
were not found:
_sqlite3           _tkinter           bsddb185
dl                 imageop            sunaudiodev
To find the necessary bits, look in setup.py in detect_modules() for the
module's name.


Failed to build these modules:
crypt              nis

The warnings during build are:

building 'nis' extension
x86_64-pc-linux-gnu-gcc -pthread -fPIC -fno-strict-aliasing -O2 -pipe
- -fomit-frame-pointer -fwrapv -I/homes/2/schlarbm/gentoo/usr/include -L/ho
mes/2/schlarbm/gentoo/lib -L/homes/2/schlarbm/gentoo/usr/lib -DNDEBUG
- -I/homes/2/schlarbm/gentoo/usr/include -I. -IInclude -I./Include -I/tmp/s
chlarbm/gentoo/portage/dev-lang/python-2.7.2/work/Python-2.7.2/Include
- -I/tmp/schlarbm/gentoo/portage/dev-lang/python-2.7.2/work/Python-2.7.2
- -c
/tmp/schlarbm/gentoo/portage/dev-lang/python-2.7.2/work/Python-2.7.2/Modules/nismodule.c
- -o
build/temp.linux-x86_64-2.7/tmp/schlarbm/gentoo/portage/dev-lang/python-2.7.2/work/Python-2.7.2/Modules/nismodule.o
x86_64-pc-linux-gnu-gcc -pthread -shared -Wl,-O1 -L. -Wl,-O1 -L.
- -fno-strict-aliasing -O2 -pipe -fomit-frame-pointer -fwrapv
- -I/homes/2/schlarbm/gentoo/usr/include -L/homes/2/schlarbm/gentoo/lib
- -L/homes/2/schlarbm/gentoo/usr/lib -DNDEBUG -I. -IInclude -I./Include
build/temp.linux-x86_64-2.7/tmp/schlarbm/gentoo/portage/dev-lang/python-2.7.2/work/Python-2.7.2/Modules/nismodule.o
- -L/homes/2/schlarbm/gentoo/usr/lib -L. -lpython2.7 -o
build/lib.linux-x86_64-2.7/nis.so
*** WARNING: renaming "nis" since importing it failed:
build/lib.linux-x86_64-2.7/nis.so: undefined symbol: yp_get_default_domain
building 'crypt' extension
x86_64-pc-linux-gnu-gcc -pthread -fPIC -fno-strict-aliasing -O2 -pipe
- -fomit-frame-pointer -fwrapv -I/homes/2/schlarbm/gentoo/usr/include -L/ho
mes/2/schlarbm/gentoo/lib -L/homes/2/schlarbm/gentoo/usr/lib -DNDEBUG
- -I/homes/2/schlarbm/gentoo/usr/include -I. -IInclude -I./Include -I/tmp/s
chlarbm/gentoo/portage/dev-lang/python-2.7.2/work/Python-2.7.2/Include
- -I/tmp/schlarbm/gentoo/portage/dev-lang/python-2.7.2/work/Python-2.7.2 -
c
/tmp/schlarbm/gentoo/portage/dev-lang/python-2.7.2/work/Python-2.7.2/Modules/cryptmodule.c
- -o build/temp.linux-x86_64-2.7/tmp/schlarbm/gentoo
/portage/dev-lang/python-2.7.2/work/Python-2.7.2/Modules/cryptmodule.o
x86_64-pc-linux-gnu-gcc -pthread -shared -Wl,-O1 -L. -Wl,-O1 -L.
- -fno-strict-aliasing -O2 -pipe -fomit-frame-pointer -fwrapv
- -I/homes/2/schlarb
m/gentoo/usr/include -L/homes/2/schlarbm/gentoo/lib
- -L/homes/2/schlarbm/gentoo/usr/lib -DNDEBUG -I. -IInclude -I./Include
build/temp.linux-x86_
64-2.7/tmp/schlarbm/gentoo/portage/dev-lang/python-2.7.2/work/Python-2.7.2/Modules/cryptmodule.o
- -L/homes/2/schlarbm/gentoo/usr/lib -L. -lpytho
n2.7 -o build/lib.linux-x86_64-2.7/crypt.so
*** WARNING: renaming "crypt" since importing it failed:
build/lib.linux-x86_64-2.7/crypt.so: undefined symbol: crypt

Is there something that can be done?

- --
Moritz Schlarb
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.17 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJOffARAAoJEEXT29373YiIXXcH/RYNjAUq2fiDmeRDiujaZ6ZR
zgMrfiXSU2Vt9EtaaQm9DRhDRY8+T0vZDzHbYFeelRjdp1ya4uM3pheud/lsFu2e
9a0i90gOTw5ygQAyPgViOk7jQ9PIzomkpHPBI+OB2JG3s5aTvnOHQxbS2b5+c/RA
hMuDrC8PIBfwt75l1DvoO6O0Xdw/qF+ENalwygjX3t8N4Q5EGuWHiDCFBgBiCc1C
/cREi1IvVeZI3T98Ahv5Eq6EjDK3IXV5guMzMBwcZmaKHGEcAdxphxj/qihDLeqY
LGSpGNvYNmk2sLhr7GDolAdDyYqCYD4FhIGPi4afMnkpfPQuIGbah8kMSkoREhc=
=GDEx
-----END PGP SIGNATURE-----



Replies:
Re: Building python fails on SLES10.1 (python-2.7.2)
-- justin
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: emerge gcc 4.4.x/4.5.x fails on CentOS 5.5
Next by thread:
Re: Building python fails on SLES10.1 (python-2.7.2)
Previous by date:
Re: emerge gcc 4.4.x/4.5.x fails on CentOS 5.5
Next by date:
Re: Building python fails on SLES10.1 (python-2.7.2)


Updated Jun 18, 2012

Summary: Archive of the gentoo-alt mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.