Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-alt
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-alt@g.o
From: heroxbd@...
Subject: Re: possible input to bootstrap guide
Date: Sat, 28 Jan 2012 22:35:25 +0900
Additionally,

heroxbd@... writes:

> When I am trying to bootstrap on Ubuntu 10.04 LTS, some workarounds are 
> used:
>
> 1. wget-1.13.4-r1 begin to use autotools and depends on autoconf, which
> in turn depends on texinfo, which cannot be emerged before =gcc-4.2.
>
> workaround: emerge -1O "<=wget-1.13.4"
>
> 2. >=binutils-2.21 needs host c++ to emerge (at configure-gold). On some
> host, g++ is not available. We need to be able to bootstrap only from c.
>
> workaround: emerge -1O "<binutils-2.21"

3. when host gcc version is later than 4.2 (or 4.0? need more test), we
can just directly bootstrap with 4.5 (lastest unmasked version), the
only difference being the gcc deps such as mpfr gmp and mpc.
-- 
XU Benda
Research Center for Neutrino Science
Tohoku University
JAPAN

http://www.awa.tohoku.ac.jp/~benda


References:
possible input to bootstrap guide
-- heroxbd
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
possible input to bootstrap guide
Next by thread:
coreutils' dependence on gperf
Previous by date:
Re: XCode 4.3
Next by date:
coreutils' dependence on gperf


Updated Jun 18, 2012

Summary: Archive of the gentoo-alt mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.