Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-alt
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-alt@g.o
From: Mathias Laurin <mathias.laurin@...>
Subject: Re: octave/gnuplot on OSX, no aquaterm!
Date: Tue, 24 Jun 2008 11:25:29 +0900
Hi,

Yes, sorry for mixing things up: octave ought to be the next step, I  
actually tried gnuplot only.

Both (gentoo and macports) are gnuplot 4.2.3. The patches from gentoo  
do not seem to remove anything, and configure does say it will put  
aqua in, so that is confusing. The default terminal are all present. I  
did not try compiling with USE=X (I do not want X) and I compiled  
gnuplot from macports with the 'no_x11' variant so that the X11  
terminal is not available there either.

The Portfile uses
configure.cflags-append	'-DDEFAULTTERM=\\"aqua\\"'
but this was only useful in previous versions of gnuplot. I tried to  
add it in the ebuild, too, but it did not change anything as expected.  
Apart from that, gentoo provides a few more patches, but nothing  
dealing with aqua/aquaterm.

The Portfile also uses more options: --with-readline=gnu --with-gd -- 
with-png --with-pdf

I just tried to compile gnuplot with the USE="pdf" and pdflibs fails,  
too, so I report it here as well:

  * QA Notice: Users/laurin/Library/Gentoo///Users/laurin/Library/ 
Gentoo/ double prefix
  * QA Notice: Users/laurin/Library/Gentoo///Users/laurin/Library/ 
Gentoo/usr double prefix
  * QA Notice: Users/laurin/Library/Gentoo///Users/laurin/Library/ 
Gentoo/usr/lib double prefix
  * QA Notice: Users/laurin/Library/Gentoo///Users/laurin/Library/ 
Gentoo/usr/lib/perl5 double prefix
  * QA Notice: Users/laurin/Library/Gentoo///Users/laurin/Library/ 
Gentoo/usr/lib/perl5/site_perl double prefix
  * QA Notice: Users/laurin/Library/Gentoo///Users/laurin/Library/ 
Gentoo/usr/lib/perl5/site_perl/5.8.8 double prefix
  * QA Notice: Users/laurin/Library/Gentoo///Users/laurin/Library/ 
Gentoo/usr/lib/perl5/site_perl/5.8.8/darwin-2level double prefix
  * ERROR: media-libs/pdflib-7.0.2_p8 failed:
  *   Aborting due to QA concerns: double prefix files installed
  *
  * Call stack:
  *       misc-functions.sh:756: <call install_qa_check>
  *       misc-functions.sh:243: 		die "Aborting due to QA concerns:  
double prefix files installed"
  *

I only installed gentoo on ~/Library/Gentoo, only one prefix on my  
computer.

Thank you for helping! BTW, the forum on gentoo.org is pretty dead,  
you could maybe make a sticky directing people to the mailing list.

Best Regards,
Mathias



On Jun 171, 2008, at 5:15 PM, Fabian Groffen wrote:

> Hi Mathias,
>
> On 19-06-2008 16:53:02 +0900, Mathias Laurin wrote:
>> I installed octave from gentoo, but it won't use aquaterm. Note  
>> that it
>> works from macports. What is strange is that, during the configure
>> phase, it says it has found aquaterm and is going to use it. But  
>> when I
>> start octave, there is no aqua terminal available. I tried  
>> compiling by
>> hand, same results: configure finds aquaterm but not the compiled
>> octave. I also had a look at the portfile from macports but it does  
>> not
>> contain anything special.
>
> Does MacPorts have the same version?  Does your version try to use the
> X11 terminal?  I don't see octave in the tree, would you mind sharing
> the ebuild somewhere?  Maybe gentoo-x86 made some modifications which
> break the aquaterm.
>
>
> -- 
> Fabian Groffen
> Gentoo on a different level
> -- 
> gentoo-alt@g.o mailing list
>

-- 
gentoo-alt@g.o mailing list


Replies:
Re: octave/gnuplot on OSX, no aquaterm!
-- Fabian Groffen
References:
octave/gnuplot on OSX, no aquaterm!
-- Mathias Laurin
Re: octave/gnuplot on OSX, no aquaterm!
-- Fabian Groffen
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: octave/gnuplot on OSX, no aquaterm!
Next by thread:
Re: octave/gnuplot on OSX, no aquaterm!
Previous by date:
[Q on OpenSolaris] Why can't emerge read config.sub?
Next by date:
RE: gawk failing prefix-launcher-1.2 on AIX


Updated Jun 17, 2009

Summary: Archive of the gentoo-alt mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.