Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-alt
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-alt@g.o
From: Benda Xu <heroxbd@...>
Subject: Re: Re: emerge gcc 4.4.x/4.5.x fails on CentOS 5.5
Date: Sun, 27 Nov 2011 03:41:28 +0900
Hi,<br><br>Just to narrow things down.<br><br>   env GENTOO_PATCH_EXCLUDE=10_all_gcc-default-fortify-source.patch emerge =gcc-4.5*<br><br>on CentOS 5 works, this is the point USE=vanilla actually do the click.<br><br>that patch is for tuning on -D_FORTIFY_SOURCE=2 by default for C, C++, ObjC, ObjC++, which is mostly for hardening the system. I guess we can disable it on certain systems.<br>
<br>BTW, One strange thing is that USE=-fortran emerge =gcc-4.5* works too.<br><br>Yours,<br>Benda<br><br><div class="gmail_quote">On Sat, Sep 24, 2011 at 10:57 PM, Moritz Schlarb <span dir="ltr">&lt;<a href="mailto:mail@...">mail@...</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div class="im"><br>
</div>It worked! (Compiling it.)<br>
I will continue with the alt-prefix handbook and report, if I experience<br>
breakages now.<br></blockquote></div><br clear="all"><br>-- <br>XU Benda<br>Research Center for Neutrino Science<br>Tohoku University<br>JAPAN<br><br><a href="http://www.awa.tohoku.ac.jp/~benda">http://www.awa.tohoku.ac.jp/~benda</a><br>

References:
Re: emerge gcc 4.4.x/4.5.x fails on CentOS 5.5
-- Martin Luessi
Re: emerge gcc 4.4.x/4.5.x fails on CentOS 5.5
-- Moritz Schlarb
Re: emerge gcc 4.4.x/4.5.x fails on CentOS 5.5
-- Fabian Groffen
Re: emerge gcc 4.4.x/4.5.x fails on CentOS 5.5
-- Moritz Schlarb
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: emerge gcc 4.4.x/4.5.x fails on CentOS 5.5
Next by thread:
Building python fails on SLES10.1 (python-2.7.2)
Previous by date:
Re: Dropping ia64-linux - anyone care?
Next by date:
Re: Gentoo Prefix: getting around the "Your OpenSSL headers do not match your library" configure error.


Updated Jun 18, 2012

Summary: Archive of the gentoo-alt mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.