Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-alt
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-alt@g.o
From: Fabian Groffen <grobian@g.o>
Subject: Re: octave/gnuplot on OSX, no aquaterm!
Date: Tue, 24 Jun 2008 11:25:34 +0200
On 24-06-2008 11:25:29 +0900, Mathias Laurin wrote:
> Both (gentoo and macports) are gnuplot 4.2.3. The patches from gentoo do 
> not seem to remove anything, and configure does say it will put aqua in, 
> so that is confusing. The default terminal are all present. I did not try 
> compiling with USE=X (I do not want X) and I compiled gnuplot from 
> macports with the 'no_x11' variant so that the X11 terminal is not 
> available there either.

ok.

> The Portfile uses
> configure.cflags-append	'-DDEFAULTTERM=\\"aqua\\"'
> but this was only useful in previous versions of gnuplot. I tried to add 
> it in the ebuild, too, but it did not change anything as expected. Apart 
> from that, gentoo provides a few more patches, but nothing dealing with 
> aqua/aquaterm.

Could be that they interfere somehow.

> The Portfile also uses more options: --with-readline=gnu --with-gd -- 
> with-png --with-pdf
>
> I just tried to compile gnuplot with the USE="pdf" and pdflibs fails,  
> too, so I report it here as well:

the package pdflibs fails or gnuplot?  The latter seems to compile and
install just fine here.

> Thank you for helping! BTW, the forum on gentoo.org is pretty dead, you 
> could maybe make a sticky directing people to the mailing list.

I'm not even sure if I can do that, but maybe it makes sense.  Thanks
for the suggestion!


-- 
Fabian Groffen
Gentoo on a different level
-- 
gentoo-alt@g.o mailing list


Replies:
Re: octave/gnuplot on OSX, no aquaterm!
-- Fabian Groffen
References:
octave/gnuplot on OSX, no aquaterm!
-- Mathias Laurin
Re: octave/gnuplot on OSX, no aquaterm!
-- Fabian Groffen
Re: octave/gnuplot on OSX, no aquaterm!
-- Mathias Laurin
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: octave/gnuplot on OSX, no aquaterm!
Next by thread:
Re: octave/gnuplot on OSX, no aquaterm!
Previous by date:
Re: portage problems...
Next by date:
Re: gawk failing prefix-launcher-1.2 on AIX


Updated Jun 17, 2009

Summary: Archive of the gentoo-alt mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.