Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-alt
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-alt@g.o
From: Fabian Groffen <grobian@g.o>
Subject: Re: portage bug ?
Date: Wed, 31 Aug 2011 11:46:54 +0200
On 31-08-2011 11:45:27 +0200, Burcin Erocal wrote:
> I didn't have time to test the patch myself, since we already have a
> report of it not working, here is a justification for my patch...
> 
> AFAICT, the original error message indicates that more arguments are
> provided to % than there are place holders in the string. The +
> operator has lower precedence than %, so the string is not concatenated
> with the part on the previous line. Note that the string in the error
> message has 3 place holders only, the fourth should come from the line
> above. I added parenthesis around the string addition to fix the
> precedence problem.

Aha.  That explains.  Now I understand why the fix fixes it as well.
I'll apply it ASAP.  Thanks a lot!


-- 
Fabian Groffen
Gentoo on a different level
Attachment:
signature.asc (Digital signature)
Replies:
Re: portage bug ?
-- Burcin Erocal
References:
portage bug ?
-- Alan Hourihane
Re: portage bug ?
-- Burcin Erocal
Re: portage bug ?
-- Fabian Groffen
Re: portage bug ?
-- Fabian Groffen
Re: portage bug ?
-- Burcin Erocal
Navigation:
Lists: gentoo-alt: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: portage bug ?
Next by thread:
Re: portage bug ?
Previous by date:
Re: portage bug ?
Next by date:
Re: portage bug ?


Updated Jun 18, 2012

Summary: Archive of the gentoo-alt mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.