Gentoo Archives: gentoo-amd64

From: Zac Medico <zmedico@×××××.com>
To: gentoo-amd64@l.g.o
Subject: Re: [gentoo-amd64] Messed up virtual/glibc?
Date: Mon, 11 Jul 2005 11:55:56
Message-Id: 42D25DDD.90302@gmail.com
In Reply to: [gentoo-amd64] Messed up virtual/glibc? by Richard Freeman
Richard Freeman wrote:
> -----BEGIN PGP SIGNED MESSAGE----- > Hash: SHA1 > > For some reason after upgrading glibc yesterday many packages cannot be > emerged: > emerge -puD world > > These are the packages that I would merge, in order: > > Calculating world dependencies / > emerge: there are no ebuilds to satisfy "virtual/glibc". > > > !!! Problem with ebuild media-gfx/gimp-print-4.2.7 > !!! Possibly a DEPEND/*DEPEND problem. > > !!! Depgraph creation failed. > > I do have sys-libs/glibc-2.3.5 installed, and I'm running > portage-2.0.51.22-r1. > > This isn't just one package - if I mask the one that is complaining I'll > end up getting a complaint about another package. > > revdep-rebuild didn't help either. > > I've tried reinstalling glibc several times, and I've checked that > CHOST=CTARGET=CBUILD in emerge info. > > Taking a quick look at glibc I see that it provides virtual/libc. Why > are other packages looking for virtual/glibc? It seems to be more than > one. Also - gimp-print does not contain any reference to virtual/glibc. > > Does anybody have any ideas why portage is looking for virtual/glibc? > -----BEGIN PGP SIGNATURE----- > Version: GnuPG v1.4.1 (GNU/Linux) > Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org > > iD8DBQFC0cIDg2bN8aFizRkRAnFLAJ4/vQo7hq6IOtyPRbXPN8eNdgWf7ACdFwtG > KRRR6NeKtcPdxAGlfwIqM2A= > =lqFt > -----END PGP SIGNATURE-----
I think you've gotten a virtual/glibc typo in one of your ebuilds (where did that "g" come from???). Have you tried more than one portage snapshot? Do you have PORTDIR_OVERLAY set? Zac -- gentoo-amd64@g.o mailing list

Replies

Subject Author
Re: [gentoo-amd64] Messed up virtual/glibc? Richard Freeman <rich0@×××××××.net>