Gentoo Archives: gentoo-amd64

From: Sebastian Zaffarano <hermetica@×××××.com>
To: gentoo-amd64@l.g.o
Subject: [gentoo-amd64] Re: nvidia-kernel compile problem
Date: Wed, 16 Nov 2005 01:00:20
Message-Id: cee590710511151657q3d16cdbg190553a7f5c22f6a@mail.gmail.com
In Reply to: Re: [gentoo-amd64] nvidia-kernel compile problem by "Mickaël Bucas"
thanks Mickael!

I'm going to install this version...

On 11/15/05, Mickaël Bucas <mbucas@×××××.com> wrote:
> On http://www.nvidia.com/object/linux_display_amd64_1.0-7676.html you will > find the latest version (7676). > > That's the one I use, it works for me, but I installed it manually (i.e. no > emerge) > And I don't use Gentoo Kernel either... > > I also had problems with 32 bit compatibility libraries, they overwrite 64 > bit libs and prevent display from working. Try to not install them. > > Mickaël Bucas > > 2005/11/15, Sebastian Zaffarano <hermetica@×××××.com>: > > > > Hi, after do an emerge world and update my kernel to 2.6.13-gentoo-r5, > > I'm get an error when I try to compile nvidia-kernel: > > > > > > > ............................................................................................................ > > x86_64-1.0-7667-pkg2/usr/src/nv/nv-vm.o > > /var/tmp/portage/nvidia-kernel-1.0.7667/work/NVIDIA-Linux-x86_64- > > 1.0-7667-pkg2/usr/src/nv/nv-vm.c > > /var/tmp/portage/nvidia-kernel-1.0.7667/work/NVIDIA-Linux-x86_64- > > 1.0-7667-pkg2/usr/src/nv/nv-vm.c: > > In function `nv_vm_malloc_pages': > > /var/tmp/portage/nvidia-kernel-1.0.7667/work/NVIDIA-Linux-x86_64- > > 1.0-7667-pkg2/usr/src/nv/nv-vm.c:283: > > error: too few arguments to function `vmap' > > make[3]: *** [/var/tmp/portage/nvidia-kernel-1.0.7667 > > /work/NVIDIA-Linux-x86_64-1.0-7667-pkg2/usr/src/nv/nv-vm.o] > > Error 1 > > make[2]: *** [_module_/var/tmp/portage/nvidia-kernel-1.0.7667 > > /work/NVIDIA-Linux-x86_64-1.0-7667-pkg2/usr/src/nv] > > Error 2 > > NVIDIA: left KBUILD. > > nvidia.ko failed to build! > > make[1]: *** [module] Error 1 > > make: *** [module] Error 2 > > > > > ............................................................................................................ > > > > I'm using: > > > > * gcc 3.4.4-r1 > > * glibc 2.3.5-r3 > > > > and the nvidia-kernel versions that fail, are 1.0.7* (7167-r1, 7174, > etc). > > > > Any ideas? > > > > thanks! > > Sebastian > > > > -- > > gentoo-amd64@g.o mailing list > > > > > >
-- gentoo-amd64@g.o mailing list