Gentoo Archives: gentoo-amd64

From: Duncan <1i5t5.duncan@×××.net>
To: gentoo-amd64@l.g.o
Subject: [gentoo-amd64] Re: Major update problem
Date: Thu, 10 Feb 2011 06:02:49
Message-Id: pan.2011.02.10.05.52.43@cox.net
In Reply to: Re: [gentoo-amd64] Re: Major update problem by Josh Sled
Josh Sled posted on Wed, 09 Feb 2011 01:05:10 -0500 as excerpted:

> Duncan <1i5t5.duncan@×××.net> writes: >> Jonathan Callen posted on Tue, 08 Feb 2011 16:29:35 -0500 as excerpted: >> >>> Portage 2.1 only has support for 3 sets: @world, @system, and >>> @selected. All of the other support for sets has been disabled >>> internally in the code but is otherwise present to allow easier >>> merging between the 2.1 and master branches in git. >> >> Thanks. I was wondering how I'd missed that big news! > > Well, it's still only in unstable. :) I'd hope before this goes into > stable, a News item (at least!) is created to guide users into how their > behavior needs to change.
So then sets (beyond the three above) are unmasked to ~arch, at least, then? Because last I knew they were in the (last I knew) hard-masked 2.2 series, only. So even unmasking them to ~arch would be big news, here. (And, since I run ~arch, if they're ~arch keyworded and not in package.mask, they're not masked, from my viewpoint. They might be ~arch, but that's not masked, but ~arch. Masked means either an entry in package.mask or KEYWORDS="", to me.) -- Duncan - List replies preferred. No HTML msgs. "Every nonfree program has a lord, a master -- and if you use the program, he is your master." Richard Stallman