Gentoo Archives: gentoo-amd64

From: Barry Schwartz <chemoelectric@×××××××××××××.org>
To: gentoo-amd64@l.g.o
Subject: Re: [gentoo-amd64] Possible Math Problem - Request For Verification [Solved]
Date: Sun, 26 Jun 2011 16:31:43
Message-Id: 20110626163028.GA16166@crud
In Reply to: Re: [gentoo-amd64] Possible Math Problem - Request For Verification [Solved] by Frank Peters
Frank Peters <frank.peters@×××××××.net> skribis:
> I was using gcc-4.5.2, which is the latest on Gentoo. Installing gcc-4.4.5, > the previous version, into a new slot and then using gcc-4.4.5 to run the > ucbtest I do *not* get the cabsd error. So the problem is definitely gcc.
Especially if you are worried about floating point accuracy, but in any case, I would be conservative with the compiler. I’m an ~amd64 user but by choice am using gcc-4.4.5 without graphite et al. (and even though gcc-4.5 is installed in a slot, though again without graphite et al.).