Gentoo Archives: gentoo-amd64

From: James Cloos <cloos@×××××××.com>
To: gentoo-amd64@l.g.o
Subject: Re: [gentoo-amd64] Glibc Update Breaks Open/LibreOffice -- Can't Downgrade
Date: Fri, 08 Jul 2011 22:06:18
Message-Id: m362nc32jo.fsf@jhcloos.com
In Reply to: Re: [gentoo-amd64] Glibc Update Breaks Open/LibreOffice -- Can't Downgrade by Frank Peters
>>>>> "FP" == Frank Peters <frank.peters@×××××××.net> writes:
FP> But is there a way to override the emerge refusal to allow FP> a downgrade to glibc? That is what I need to do. If you edit the glibc-2.13-r3 entry in /var/db/pkg to call it -r2, you should be able to sneak in a downgrade. Something like (untested): :; mv /var/db/pkg/sys-libs/glibc-2.13-r3 /var/db/pkg/sys-libs/glibc-2.13-r2 :; cd /var/db/pkg/sys-libs/glibc-2.13-r2 :; mv glibc-2.13-r3.ebuild glibc-2.13-r2.ebuild :; perl -pi -e 's/2.13-r3/2.13-r2/g' PF :; bunzip2 environment.bz2 :; perl -pi -e 's/2.13-r3/2.13-r2/g' environment :; bzip2 environment would probably convince portage that you have -r2 installed. It should then let you re-install -r2 via emerge =sys-libs/glibc-2.13-r2. I found a backup of my old stage3, chroot(2)ed to that, upgraded it to 2.13-r2, used quickpkg to make a pkg file (forgot to specify --buildpkg) and untar(1)ed that over / to get a working box again. -JimC -- James Cloos <cloos@×××××××.com> OpenPGP: 1024D/ED7DAEA6