Gentoo Archives: gentoo-amd64

From: Duncan <1i5t5.duncan@×××.net>
To: gentoo-amd64@l.g.o
Subject: [gentoo-amd64] Re: emerge -deep world last night has broken kde
Date: Thu, 07 Jul 2005 10:31:30
Message-Id: pan.2005.07.07.10.27.41.688077@cox.net
In Reply to: [gentoo-amd64] emerge -deep world last night has broken kde by Joel Wiramu Pauling
Joel Wiramu Pauling posted <1120725375.18318.2.camel@localhost>, excerpted
below,  on Thu, 07 Jul 2005 20:36:15 +1200:

> I did an emerge deep world last night, and noticed it pick up new kde > ebuilds. This morning KDE and almost any KDE app (with the exception of > LICQ's kde-gui plugin... which doesn't really use the framework very > much) either hangs, or hardlocks the system. > > Has anyone else doing a deep world upgrade with kde suffered this > problem? > > I am attempting to rebuild qt and kdelibs in the hope that it solves it > but this has really put a dampner on any development work I was hoping > to do before next week. > > BTW I am running ~amd64
No issues of that nature here, and the only DE I run is KDE, so if it hit, I'd DEFINITELY notice it and be scrambling to figure out the issue and get things fixed. I just resynced to be sure, altho I'd synced about 14 hours ago and updated everything. The only things a -puD lists as not updated in the ~14 hours is dev-libs/libxslt-1.1.14 (1.1.13-r1 currently merged), and sys-fs/udev-061 (060 currently merged).
>From previous updates, I still show x11-base/xorg-x11-6.8.99.14 as
unmerged (.13 currently merged). I've unmasked these snapshots locally, but .14 scrambled the second monitor in xinerama mode so I reverted to .13, and haven't reset masking to mask .14 only, yet. One POSSIBLE culprit COULD be the qt update from a few days ago. The changelog for it said the changes were only for the database folks, and I run KDE off it not any databases, so that shouldn't affect me and I just masked the new version (x11-libs/qt-3.3.4-r6, I've still -r5 merged). I've found that after merging a new Qt, KDE still works, but with a couple quirks (mainly, menus are the wrong color, but it's possible/likely there are other quirks I haven't noticed), until I remerge kdelibs as well. Since both Qt and kdelibs are rather long merges, I didn't feel like remerging both of them for a Qt version bump for database stuff that shouldn't affect me anyway, so I simply masked the bumped Qt. It's possible but not likely that this particular Qt causes other issues as well, and that's what you are observing. Do note, however, that in addition to running ~amd64, I'm running testing-masked versions of gcc (now 4.0.1_pre20050702) and binutils (2.16.91.0.1) to support gcc-4.x. I run the 4.0 gcc-config profile as my default, and have been compiling anything that will with it for some time, tho I still have gcc-3.4.x merged (in its own parallel slot, naturally) and gcc-config to it for stuff (such as xorg) that won't yet compile with gcc-4.x. Thus, much of my system, including Qt and all of KDE-3.4.1, is now gcc-4 compiled. If you are running a straight ~amd64 system, you will have everything gcc-3.x compiled, which /might/ make a difference, tho in theory my gcc-4.x compiled system should be less stable. Also, you mention that you run ~amd64, but don't mention how often you update. It's quite possible if you update only about once a week or so, compared to my usual 1-3 day updates, that my updates were processed in a different order than yours, and some dependency (qt and kdelibs as you mentioned, but also arts) needs recompiled in your case. Have you tried a revdep-rebuild lately? That /might/ catch it. -- Duncan - List replies preferred. No HTML msgs. "Every nonfree program has a lord, a master -- and if you use the program, he is your master." Richard Stallman in http://www.linuxdevcenter.com/pub/a/linux/2004/12/22/rms_interview.html -- gentoo-amd64@g.o mailing list

Replies

Subject Author
Re: [gentoo-amd64] Re: emerge -deep world last night has broken kde Joel Wiramu Pauling <aenertia@××××××××.net>