Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-amd64
Navigation:
Lists: gentoo-amd64: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-amd64@g.o
From: Edward Killips <camber@...>
Subject: Re: AMD64 linking issues.
Date: Fri, 15 Jul 2005 12:54:57 -0400
On Jul 15, 2005, at 1:41 AM, Tres Melton wrote:


> I have been working on that darned libcom_err.so.3 error that has
> plagued many of us (including those w/ x86).  I have just posted
> something to the forum and wanted to post it here to to get reactions
> from x86-64 users on my speculation in the last paragraph.  Anyway:
> ----------------------------------------------------------------
> http://forums.gentoo.org/viewtopic-p-2574850.html#2574850
>
>
That library is supplied by the MIT kerberos package and in no longer  
built by default.
I had to manually build the kerberos package and force libcom_err.so. 
3 to build.
This resolved all of the linking errors.

> Well it seems that sys-libs/com_err-1.38 and sys-libs/ss-1.38 were
> released today. I dutifully upgraded my system (along with some other
> packages) and everything seems to have gone okay. Upon conclusion I
> retried revdep-rebuild and came up with the same error:
> rm /root/.revdep-rebuild*.?_* ; revdep-rebuild
> ...
> Checking dynamic linking consistency...
> broken /emul/linux/x86/usr/lib/gtk/themes/engines/libpixmap.so  
> (requires
> libgdk_imlib.so.1)
> broken /usr/kde/3.3/lib/kde3/kio_http.so (requires libcom_err.so.3)
> done.
> (/root/.revdep-rebuild.3_rebuild)
> ...
> All prepared. Starting rebuild...
> emerge --oneshot =app-emulation/emul-linux-x86-gtklibs-2.1
> ...
> Build finished correctly. Removing temporary files...
>
> I don't have the same symptoms as others (w/ Samba) and I'm
> sure /emul/linux/x86/usr/lib/gtk/themes/engines/libpixmap.so is  
> related
> to mplayer32-bin but for some reason revdep-rebuild doesn't even  
> attempt
> to fix /usr/kde/3.3/lib/kde3/kio_http.so.
>
> "equery belongs /usr/kde/3.3/lib/kde3/kio_http.so" failed to return
> anything but "equery belongs kio_http.so" returned both
> kde-base/kdelibs-3.3.2-r9 and kde-base/kdelibs-3.4.1-r1. Do I even  
> need
> 3.3.2 if I have 3.4.1? Just to be safe with some of the older  
> packages I
> didn't --unmerge it. Manually trying to re-emerge kde-base/kdelibs
> ("emerge -avDt --newuse kde-base/kdelibs") yielded a number of "Error:
> libgd was not built with FreeType font support" which could be an
> insight into the problem as media-libs/libgd is a part of the  
> mplayer32
> package and not available as a 64 bit package. In my opinion kdelibs
> should not be linking against a 32 bit binary library. Anyway, that is
> where it stands at the moment, re-emerging kdelibs didn't change
> anything.
> ----------------------------------------------------------------
> Thoughts?
>
> Best Regards,
> -- 
> Tres
>
> -- 
> gentoo-amd64@g.o mailing list
>
>

Ed

-- 
gentoo-amd64@g.o mailing list


Replies:
Re: AMD64 linking issues.
-- Olivier Crete
References:
AMD64 linking issues.
-- Tres Melton
Navigation:
Lists: gentoo-amd64: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: AMD64 linking issues.
Next by thread:
Re: AMD64 linking issues.
Previous by date:
Re: ldconfig breaks my system
Next by date:
Re: AMD64 linking issues.


Updated Jun 17, 2009

Summary: Archive of the gentoo-amd64 mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.