Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-amd64
Navigation:
Lists: gentoo-amd64: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-amd64@g.o
From: Raj Swaminathan <rajshyam@...>
Subject: OSS modules not loaded
Date: Fri, 13 Jan 2006 01:01:19 -0600
<br>
Hi,<br>
<br>
I am having some problems with sound. I followed the ALSA guide and
used alsa-driver. I am able to hear songs on mplayer, however i dont
hear startup sounds nor can i get skype to work. <br>
<br>
<span style="text-decoration: underline;">Output of lsmod</span><br style="font-style: italic;">
<br style="font-style: italic;">
<span style="font-style: italic;">Module&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Size&nbsp; Used by</span><br style="font-style: italic;">
<span style="font-style: italic;">snd_seq&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 56672&nbsp; 0</span><br style="font-style: italic;">
<span style="font-style: italic;">nvidia&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 4855536&nbsp; 14</span><br style="font-style: italic;">
<span style="font-style: italic;">snd_intel8x0&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 34088&nbsp; 1</span><br style="font-style: italic;">
<span style="font-style: italic;">snd_ac97_codec&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 105432&nbsp; 1 snd_intel8x0</span><br style="font-style: italic;">
<span style="font-style: italic;">snd_ac97_bus&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 4480&nbsp; 1 snd_ac97_codec</span><br style="font-style: italic;">
<span style="font-style: italic;">snd_pcm&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
88776&nbsp; 2 snd_intel8x0,snd_ac97_codec</span><br style="font-style: italic;">
<span style="font-style: italic;">snd_timer&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 23752&nbsp; 2 snd_seq,snd_pcm</span><br style="font-style: italic;">
<span style="font-style: italic;">snd&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
50448&nbsp; 7 snd_seq,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer</span><br style="font-style: italic;">
<span style="font-style: italic;">snd_page_alloc&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 11856&nbsp; 2 snd_intel8x0,snd_pcm</span><br style="font-style: italic;">
<span style="font-style: italic;">ndiswrapper&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 206304&nbsp; 0<br>
<span style="font-style: italic;"><br>
</span></span><span style="text-decoration: underline;">Output of cat /etc/modules.d/alsa</span><br>
<br>
<span style="font-style: italic;">alias snd-card-0 snd-intel8x0</span><br style="font-style: italic;">

<span style="font-style: italic;">alias sound-slot-0 snd-intel8x0</span><br style="font-style: italic;">
<br>
<span style="font-weight: bold;"></span>Basic dmix works <br>
<pre>alsaplayer -o alsa -d plug:dmix some.mp3 &amp;<br>$ aplay -D plug:dmix some.wav &amp;<br>$ alsaplayer -o alsa -d plug:dmix some.mp3 &amp;<br></pre>
So does this<br>
&nbsp;aoss mpg321 some.mp3, <br>
<br>
When i make a skype call .. i get the following messages on the console<br>
<br>
<span style="font-style: italic;">volume_open: error opening /dev/mixer: No such file or directory</span><br style="font-style: italic;">
<span style="font-style: italic;">volume_open: error opening /dev/mixer: No such file or directory</span><br style="font-style: italic;">
<span style="font-style: italic;">volume_open: error opening /dev/mixer: No such file or directory</span><br style="font-style: italic;">
<span style="font-style: italic;">/dev/dsp-1: No such file or directory</span><br style="font-style: italic;">
<span style="font-style: italic;"></span><br>
<br>
<br>
<br>
<span style="font-style: italic;"><span style="font-style: italic;"><span style="font-style: italic;"></span></span></span><br style="font-style: italic;">
<span style="font-style: italic;"></span><br style="font-style: italic;">
<br style="font-style: italic;">
<br style="font-style: italic;">
<br>
Replies:
Re: OSS modules not loaded
-- Harm Geerts
Navigation:
Lists: gentoo-amd64: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Gentoo/AMD64 Project Status Report
Next by thread:
Re: OSS modules not loaded
Previous by date:
Re: some xorg related questions
Next by date:
Re: OSS modules not loaded


Updated Jun 17, 2009

Summary: Archive of the gentoo-amd64 mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.