Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-amd64
Navigation:
Lists: gentoo-amd64: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-amd64@g.o
From: Frank Peters <frank.peters@...>
Subject: Alsa Problem With Kernel 2.6.37
Date: Sat, 8 Jan 2011 11:28:17 -0500
Hello,

I would like to ask the list for some confirmation regarding a sudden
problem I am having with Alsa sound.  The 2.6.37 kernel was just released
and I immediately compiled and installed it.  This is the plain vanilla 
kernel source which is the same as is available at kernel.org.

Now, Alsa sound does not work.  Everything on my system is the same except
for the new kernel 2.6.37.

The problem, as far as I can determine, is that the usual sound devices
are not being detected.  The Alsa sound modules load properly and my sound
card appears in the list shown by lspci.  But doing an strace with any of the
Alsa utilities always shows the following:

open("/dev/snd/controlC0", O_RDONLY|O_CLOEXEC) = -1 ENODEV (No such device)
open("/dev/aloadC0", O_RDONLY|O_CLOEXEC) = -1 ENODEV (No such device)

These devices do exist.  I can reboot with kernel 2.6.36 and the sound
works normally, but for some reason, the new kernel 2.6.37 modules cannot detect
these devices.

There are two sound "cards" available on my machine.  One is the Intel HDA
built into the motherboard (which I don't ordinarily use) and the other is a
PCI M-Audio Delta 2496 (Alsa ice1712 driver).  Alsa modules for both cards show
the same failure, and both cards exhibit no problems with kernel 2.6.36.

I already posted a report of this issue on the Alsa-users list but received
no response.  Before I go posting more reports I just want to ask for some
confirmation.  Has anyone installed the new 2.6.37 kernel and gotten functioning
sound?

Frank Peters


Replies:
Re: Alsa Problem With Kernel 2.6.37[Solved]
-- Frank Peters
Re: Alsa Problem With Kernel 2.6.37
-- Duncan
Re: Alsa Problem With Kernel 2.6.37
-- Nikos Chantziaras
Navigation:
Lists: gentoo-amd64: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Some multimedia keys not working
Next by thread:
Re: Alsa Problem With Kernel 2.6.37
Previous by date:
Re: Re: Memory usage; 32 bit vs 64 bit.
Next by date:
Re: Alsa Problem With Kernel 2.6.37


Updated Jun 28, 2012

Summary: Archive of the gentoo-amd64 mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.