Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-amd64
Navigation:
Lists: gentoo-amd64: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: Gentoo AMD64 <gentoo-amd64@g.o>, Gentoo Users <gentoo-user@g.o>
From: Alex Bennee <alex@...>
Subject: ldconfig breaks my system
Date: Fri, 15 Jul 2005 13:31:53 +0100
Hi,

Applogies for the cross-post. I'm unsure if this is and amd64 specific
problem or a more general b0rkage.

I've posted about my failing glibc emerges before:

http://thread.gmane.org/gmane.linux.gentoo.user/114627

I think I've narrowed it down to ldconfig running during the emerge. In
fact at the moment any time I run ldconfig it breaks the system so that
I cannot spawn any new shells (they segfault straight away). I can
restore my system by untaring a rescue glibc binary.

Can anyone give me any hints on how to diagnose the problem with
ldconfig and why things stop working when its done?

I'm currently building a parallel world on a second partition (in a
chrooted environment) to see if there are any differences between the
two setups (i.e a subtle breakage occured and was never picked up).

--
Alex, homepage: http://www.bennee.com/~alex/
It destroys one's nerves to be amiable every day to the same human
being. -- Benjamin Disraeli

-- 
gentoo-amd64@g.o mailing list


Replies:
Re: ldconfig breaks my system
-- Zac Medico
Navigation:
Lists: gentoo-amd64: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
AMD64 linking issues.
Next by thread:
Re: ldconfig breaks my system
Previous by date:
Re: AMD64 linking issues.
Next by date:
Re: Thunderbird - firefox links not opening


Updated Jun 17, 2009

Summary: Archive of the gentoo-amd64 mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.