Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-amd64
Navigation:
Lists: gentoo-amd64: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-amd64@g.o
From: Mateusz Arkadiusz Mierzwinski <mateuszmierzwinski@...>
Subject: Re: About to install on a 64 bit system. Advice wanted.
Date: Thu, 9 Dec 2010 15:09:48 +0100
Dale, I tell You one thing - choose multilib. This don&#39;t do nothing wrong. You can use 32-bit app compatibility and this don&#39;t reduce performance of overall system. Easyest way for Me is:<br><br>- boot minimal CD<br>
- format drive (partitioned allready)<br>- fetch with links stage3 od amd64<br>- fetch portage<br>- unpack<br>- mounting binded dev and mounting proc, copy resolv.conf<br>- chroot and update environment by env-update, source<br>
- set environment (timezone, fstab, net)<br>- emerge some standard packages (vixie-cron, syslog-ng, dhcp, dbus, hal, udev) and making global system update (-uva --deep system), setting USE flags and CXXFLAGS as needed.<br>
- emerge lilo, genkernel, gentoo-sources<br>- setting genkernel with menuconfig and run kernel compilation<br>- configure lilo ;) and running lilo.<br>- reboot<br>- emerging rest of software - aka KDE4 - this will push all packages needed (aka. kde-meta will take deps like xorg, mesa and else so You don&#39;t have to worry about - enable hal flag for convenience :) ).<br>
<br>Done! Works for me, without any incovenience, as You see nothing strange happens, os is working without any strange things to do. You can set now KDE profile, it should be listed by eselect for portage optimization.<br>
<br>One You should do: choose lilo - it&#39;s old, it&#39;s good, it&#39;s tested. Configuration is fast and it&#39;s up and runnning in no time. Multilib you should set for some applications compatibility if You will fetch in future some deb/rpm packages from third party companies. <br>
<br><br>Be aware _lastest_ available in portage flash player - it has no support for 64bit browser (i don&#39;t know why). I&#39;ve needed to get downgrade by hand. Now after each upgrade flash player must be downgraded by hand (sic!) i will mask it in packages.mask localy ;).<br>
<br>That&#39;s it - pure purity (64-bit only) can make you sick later, ill tell You ;)<br><br><br><div class="gmail_quote">2010/12/9 Paul Jewell <span dir="ltr">&lt;<a href="mailto:paul@...">paul@...</a>&gt;</span><br>
<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">When I installed my system back in January, I started off with 64 bit only, and immediately hit a problem with grub compilation. I switched to multilib, and the installation went smoothly. I would recommend Pappy&#39;s seeds as a starting point for kernel configuration. Even if you don&#39;t use his seed, the debian resource to identify drivers is useful. If you need a link, I&#39;ll sort it out when I get home. I have not had any issues with the multilib setup, and compared to my old AthlonXP system it flies!<br>

<br>
Rgds.,<br>
<font color="#888888">Paul<br>
</font><div><div></div><div class="h5">-----Original Message-----<br>
From: Florian Philipp &lt;<a href="mailto:lists@...">lists@...</a>&gt;<br>
Date: Thu, 09 Dec 2010 10:48:29<br>
To: &lt;<a href="mailto:gentoo-amd64@g.o">gentoo-amd64@g.o</a>&gt;<br>
Reply-to: <a href="mailto:gentoo-amd64@g.o">gentoo-amd64@g.o</a><br>
Subject: Re: [gentoo-amd64] About to install on a 64 bit system. Advice wanted.<br>
<br>
Am 09.12.2010 06:29, schrieb Dale:<br>
&gt; Mateusz Arkadiusz Mierzwinski wrote:<br>
[...]<br>
&gt;&gt;     Frank Peters wrote:<br>
&gt;&gt;<br>
&gt;&gt;         On Wed, 08 Dec 2010 15:17:18 -0600<br>
&gt;&gt;         Dale&lt;<a href="mailto:rdalek1967@...">rdalek1967@...</a> &lt;mailto:<a href="mailto:rdalek1967@...">rdalek1967@...</a>&gt;&gt;  wrote:<br>
[...]<br>
&gt;&gt;             What are some things that I should watch for and enable<br>
&gt;&gt;             that isn&#39;t so<br>
&gt;&gt;             obvious for someone new to 64 bit?<br>
[...]<br>
&gt;&gt;         The first thing to decide is whether or not you want a pure 64-bit<br>
&gt;&gt;         system or a 64-bit system that keeps 32-bit capability.<br>
&gt;&gt;<br>
&gt;&gt;         I am a purist.  I left 32-bit programs in the dust a long time<br>
&gt;&gt;         ago.<br>
&gt;&gt;         But as a consequence there are some things that I will miss<br>
&gt;&gt;         because<br>
&gt;&gt;         they are available in 32-bit packages only.  An example would be<br>
&gt;&gt;         Acroread, the PDF viewer, from Adobe.  Without Acroread, you will<br>
&gt;&gt;         only view pdf files through the 64-bit xpdf.  The Intel C++<br>
&gt;&gt;         compiler is another example.  In fact, most commercial software<br>
&gt;&gt;         that bothers to release a Linux version will do so in 32-bit<br>
&gt;&gt;         format only.<br>
[...]<br>
&gt;&gt; You can set it in KERNEL by disabling 32 bit application support and<br>
&gt;&gt; recompiling GLIBC and GCC without MULTILIB ;). Try also running 32 bit<br>
&gt;&gt; app. System is not slower or anything else wrong happens. If You drop<br>
&gt;&gt; 32-bit support You cannot use WINE and load PE32 apps (aka Win32).<br>
&gt;&gt;<br>
[...]<br>
&gt; I don&#39;t use Wine.  I have never heard of PE32 so I don&#39;t guess I have a<br>
&gt; need for it either.  lol   It sounds like I should go pure 64 bit.<br>
&gt; Anyone disagree with that?  Someone mentioned pdf files but I can use<br>
&gt; KDE&#39;s program for that as I do now.  I can use OOo as a backup too.<br>
&gt; [...]<br>
<br>
Didn&#39;t you post on gentoo-user that you watch youtube videos? Well, the<br>
currently stable version of adobe-flash (10.1.102.64) is 32bit-only.<br>
That will change again with the next higher version in the tree but the<br>
switch to 32bit can happen again when Adobe decides once again that it<br>
doesn&#39;t need to fix its security bugs for amd64.<br>
<br>
You might also want to think about pre-compiled OSS applications in<br>
portage (`eix -- -bin`). Not all of them come in pure 64bit flavor.<br>
<br>
AFAIK there are only two reasons to avoid a multilib setup:<br>
1. Disk space (~230MB on my system)<br>
2. Compile time on packages that support multilib.<br>
<br>
I don&#39;t think either of these will be an issue for your new system ;)<br>
IMHO the increased flexibility is well worth the effort.<br>
<br>
Hope this helps,<br>
Florian Philipp<br>
<br>
<br>
</div></div></blockquote></div><br><br clear="all"><br>-- <br>Mateusz Mierzwiński<br><br>Bluebox Software <a href="http://www.blueboxsoft.pl/mateusz-mierzwinski" target="_blank">http://www.blueboxsoft.pl/mateusz-mierzwinski</a><br>

Replies:
Re: About to install on a 64 bit system. Advice wanted.
-- Mark Knecht
References:
About to install on a 64 bit system. Advice wanted.
-- Dale
Re: About to install on a 64 bit system. Advice wanted.
-- Frank Peters
Re: About to install on a 64 bit system. Advice wanted.
-- Dale
Re: About to install on a 64 bit system. Advice wanted.
-- Mateusz Arkadiusz Mierzwinski
Re: About to install on a 64 bit system. Advice wanted.
-- Dale
Re: About to install on a 64 bit system. Advice wanted.
-- Florian Philipp
Re: About to install on a 64 bit system. Advice wanted.
-- Paul Jewell
Navigation:
Lists: gentoo-amd64: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: About to install on a 64 bit system. Advice wanted.
Next by thread:
Re: About to install on a 64 bit system. Advice wanted.
Previous by date:
Re: About to install on a 64 bit system. Advice wanted.
Next by date:
Re: About to install on a 64 bit system. Advice wanted.


Updated Jun 28, 2012

Summary: Archive of the gentoo-amd64 mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.