Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-amd64
Navigation:
Lists: gentoo-amd64: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-amd64@g.o
From: Peter Humphrey <prh@...>
Subject: Re: Now I have a problem with l32 too
Date: Wed, 21 Dec 2005 13:08:05 +0000
Mark Knecht wrote:

> So version 1.1.1 is a big improvement for me, but I'm still having
> some troubles:

Me too [/aol]

Now I get the expected `uname -m` result for root as well as for me, but I 
can't run any X programs because the DISPLAY variable isn't set, thus:

prh@gentoo32 ~ $ xterm
xterm Xt error: Can't open display:
xterm:  DISPLAY is not set

xhost doesn't help me either:

prh@wstn ~ $ xhost local:localhost
non-network local connections being added to access control list
prh@wstn ~ $ l32 bash
prh@gentoo32 ~ $ sh /usr/local/src/install-crossover-standard-5.0.0.sh
Verifying archive integrity...OK
Uncompressing CrossOver Office Standard
<snip>
The DISPLAY variable is not set.  You cannot install this program from a
console.  Run startx or xinit to start an X server first before running setup.


> 2) I'm still having to do the xhost thing to get it to work.

This is what I get when I try to run a program from an xterm:

prh@wstn ~ $ xhost local:localhost
non-network local connections being added to access control list
prh@wstn ~ $ l32 bash
prh@gentoo32 ~ $ sh /usr/local/src/install-crossover-standard-5.0.0.sh 
Verifying archive integrity...OK
Uncompressing CrossOver Office
<snip>
The DISPLAY variable is not set.  You cannot install this program from a
console.  Run startx or xinit to start an X server first before running setup.

Or if I try putting all the commands on a single line (sorry about the 
wrapping):

prh@wstn ~ $ xhost local:localhost && l32 
/usr/local/src/install-crossover-standard-5.0.0.sh
non-network local connections being added to access control list
/bin/bash: /usr/local/src/install-crossover-standard-5.0.0.sh: Permission denied

Clearly, I still have much to learn.
-- 
gentoo-amd64@g.o mailing list


Replies:
Re: Now I have a problem with l32 too
-- Billy Holmes
References:
Now I have a problem with l32 too
-- Peter Humphrey
Re: Now I have a problem with l32 too
-- Billy Holmes
Re: Now I have a problem with l32 too
-- Mark Knecht
Navigation:
Lists: gentoo-amd64: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Now I have a problem with l32 too
Next by thread:
Re: Now I have a problem with l32 too
Previous by date:
Re: /var/log
Next by date:
Re: Problems getting started


Updated Jun 17, 2009

Summary: Archive of the gentoo-amd64 mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.