Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-amd64
Navigation:
Lists: gentoo-amd64: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-amd64@g.o
From: Steve Herber <herber@...>
Subject: Re: Warning bash-3.1 serious issue starting init scripts bug #115142
Date: Sun, 11 Dec 2005 23:29:02 -0800 (PST)
I ran into the same problem but I could get a root prompt.  I found that
a number of /etc/init.d/scripts and some of the portage support scripts
contained lines like this:

         local -a umods=()

or something like that.  It seems the new 3.1 bash does not like the
=() syntax.  I just removed the =() from the ones I found causing reboot
problems, at least until I got my network link back.  Then I masked out
the new version and reverted to the previous version.


Steve Herber	herber@...		work: 206-221-7262
Security Engineer, UW Medicine, IT Services	home: 425-454-2399

On Sun, 11 Dec 2005, Joerg Gollnick wrote:

> I had a serious issue in bash-3.1 which was documented in
> http://bugs.gentoo.org/show_bug.cgi?id=115142.
> I had no possiblity to get a network connection, be warned.
> At the moment it seems that package.mask is updated a few minutes ago on the
> mirror.
> Best regard Joerg
>
> -- 
> gentoo-amd64@g.o mailing list
-- 
gentoo-amd64@g.o mailing list


Replies:
Re: Warning bash-3.1 serious issue starting init scripts bug #115142
-- Rudmer van Dijk
References:
Warning bash-3.1 serious issue starting init scripts bug #115142
-- Joerg Gollnick
Navigation:
Lists: gentoo-amd64: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Warning bash-3.1 serious issue starting init scripts bug #115142
Next by thread:
Re: Warning bash-3.1 serious issue starting init scripts bug #115142
Previous by date:
Re: Re: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown block(2,0)
Next by date:
Re: Warning bash-3.1 serious issue starting init scripts bug #115142


Updated Jun 17, 2009

Summary: Archive of the gentoo-amd64 mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.