Gentoo Archives: gentoo-announce

From: Pierre-Yves Rofes <py@g.o>
To: gentoo-announce@l.g.o, full-disclosure@××××××××××××××.uk, bugtraq@×××××××××××××.com, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] [ GLSA 200711-01 ] gFTP: Multiple vulnerabilities
Date: Thu, 01 Nov 2007 23:09:04
Message-Id: 472A680B.8020207@gentoo.org
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200711-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: gFTP: Multiple vulnerabilities
      Date: November 01, 2007
      Bugs: #188252
        ID: 200711-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Two buffer overflow vulnerabilities have been discovered in fsplib code
used in gFTP.

Background
==========

gFTP is an FTP client for the GNOME desktop environment.

Affected packages
=================

    -------------------------------------------------------------------
     Package       /   Vulnerable   /                       Unaffected
    -------------------------------------------------------------------
  1  net-ftp/gftp      < 2.0.18-r6                        >= 2.0.18-r6

Description
===========

Kalle Olavi Niemitalo discovered two boundary errors in fsplib code
included in gFTP when processing overly long directory or file names.

Impact
======

A remote attacker could trigger these vulnerabilities by enticing a
user to download a file with a specially crafted directory or file
name, possibly resulting in the execution of arbitrary code
(CVE-2007-3962) or a Denial of Service (CVE-2007-3961).

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All gFTP users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-ftp/gftp-2.0.18-r6"

References
==========

  [ 1 ] CVE-2007-3961
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-3961
  [ 2 ] CVE-2007-3962
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-3962

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200711-01.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHKmgLuhJ+ozIKI5gRAkHDAJ0bKesCCZXTosLIHdxRbEMF0qG1kgCeN+cX
+YXc0ftTGX5B5cD1DrdrrtU=
=n1oZ
-----END PGP SIGNATURE-----
-- 
gentoo-announce@g.o mailing list