Gentoo Archives: gentoo-announce

From: Tim Sammut <underling@g.o>
To: gentoo-announce@g.o
Cc: bugtraq@×××××××××××××.com, full-disclosure@××××××××××××××.uk, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] [ GLSA 201111-04 ] phpDocumentor: Function call injection
Date: Fri, 11 Nov 2011 22:32:13
Message-Id: 4EBDA0B2.6040602@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201111-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: phpDocumentor: Function call injection
     Date: November 11, 2011
     Bugs: #213318
       ID: 201111-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

phpDocumentor bundles Smarty which contains an input sanitation flaw,
allowing attackers to call arbitrary PHP functions.

Background
==========

The phpDocumentor package provides automatic documenting of PHP API
directly from the source.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-php/PEAR-PhpDocumentor
                                 < 1.4.3-r1               >= 1.4.3-r1

Description
===========

phpDocumentor bundles Smarty with the modifier.regex_replace.php
plug-in which does not properly sanitize input related to the ASCII NUL
character in a search string.

Impact
======

A remote attacker could call arbitrary PHP functions via templates.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All phpDocumentor users should upgrade to the latest stable version:

  # emerge --sync
  # emerge --ask --oneshot -v ">=dev-php/PEAR-PhpDocumentor-1.4.3-r1"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since February 12, 2011. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2008-1066
      http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2008-1066

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201111-04.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature