Gentoo Archives: gentoo-announce

From: Matthias Geerdsen <vorlon@g.o>
To: gentoo-announce@g.o
Cc: bugtraq@×××××××××××××.com, full-disclosure@××××××××××××××.uk, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] [ GLSA 200709-08 ] id3lib: Insecure temporary file creation
Date: Sat, 15 Sep 2007 16:10:46
Message-Id: 46EBFD44.1030305@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200709-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: id3lib: Insecure temporary file creation
      Date: September 15, 2007
      Bugs: #189610
        ID: 200709-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability has been discovered in id3lib allowing local users to
overwrite arbitrary files via a symlink attack.

Background
==========

id3lib is an open-source, cross-platform software development library
for reading, writing, and manipulating ID3v1 and ID3v2 tags.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  media-libs/id3lib     < 3.8.3-r6                      >= 3.8.3-r6

Description
===========

Nikolaus Schulz discovered that the function RenderV2ToFile() in file
src/tag_file.cpp creates temporary files in an insecure manner.

Impact
======

A local attacker could exploit this vulnerability via a symlink attack
to overwrite arbitrary files.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All id3lib users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=media-libs/id3lib-3.8.3-r6"

References
==========

  [ 1 ] CVE-2007-4460
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4460

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200709-08.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature