Gentoo Archives: gentoo-announce

From: Alex Legler <a3li@g.o>
To: gentoo-announce@l.g.o
Cc: bugtraq@×××××××××××××.com, full-disclosure@××××××××××××××.uk, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] [ GLSA 201111-09 ] Perl Safe module: Arbitrary Perl code injection
Date: Sun, 20 Nov 2011 18:30:01
Message-Id: 201111201914.07633.a3li@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201111-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Perl Safe module: Arbitrary Perl code injection
     Date: November 20, 2011
     Bugs: #325563
       ID: 201111-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The Safe module for Perl does not properly restrict code, allowing a
remote attacker to execute arbitrary Perl code outside of a restricted
compartment.

Background
==========

Safe is a Perl module to compile and execute code in restricted
compartments.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  perl-core/Safe                < 2.27                     >= 2.27 
  2  virtual/perl-Safe             < 2.27                     >= 2.27 
    -------------------------------------------------------------------
     2 affected packages
    -------------------------------------------------------------------

Description
===========

Unsafe code evaluation prevents the Safe module from properly
restricting the code of implicitly called methods on implicitly blessed
objects.

Impact
======

A remote attacker could entice a user to load a specially crafted Perl
script, resulting in execution arbitrary Perl code outside of a
restricted compartment.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All users of the standalone Perl Safe module should upgrade to the
latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=perl-core/Safe-2.27"

All users of the Safe module bundled with Perl should upgrade to the
latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=virtual/perl-Safe-2.27"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since July 18, 2010. It is likely that your system is already
no longer affected by this issue.

References
==========

[ 1 ] CVE-2010-1168
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-1168

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201111-09.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature