Gentoo Archives: gentoo-announce

From: Alex Legler <a3li@g.o>
To: gentoo-announce@l.g.o
Cc: bugtraq@×××××××××××××.com, full-disclosure@××××××××××××××.uk, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] [ GLSA 200906-02 ] Ruby: Denial of Service
Date: Sun, 28 Jun 2009 21:37:40
Message-Id: 1246224918.5085.0.camel@localhost
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200906-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Ruby: Denial of Service
      Date: June 28, 2009
      Bugs: #273213
        ID: 200906-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A flaw in the Ruby standard library might allow remote attackers to
cause a Denial of Service attack.

Background
==========

Ruby is an interpreted object-oriented programming language. The
elaborate standard library includes the "BigDecimal" class.

Affected packages
=================

    -------------------------------------------------------------------
     Package        /   Vulnerable   /                      Unaffected
    -------------------------------------------------------------------
  1  dev-lang/ruby     < 1.8.6_p369                      >= 1.8.6_p369

Description
===========

Tadayoshi Funaba reported that BigDecimal in
ext/bigdecimal/bigdecimal.c does not properly handle string arguments
containing overly long numbers.

Impact
======

A remote attacker could exploit this issue to remotely cause a Denial
of Service attack.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Ruby users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-lang/ruby-1.8.6_p369"

References
==========

  [ 1 ] CVE-2009-1904
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1904

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200906-02.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature