Gentoo Archives: gentoo-announce

From: Alex Legler <a3li@g.o>
To: gentoo-announce@l.g.o
Cc: bugtraq@×××××××××××××.com, full-disclosure@××××××××××××××.uk, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] [ GLSA 201006-21 ] UnrealIRCd: Multiple vulnerabilities
Date: Mon, 14 Jun 2010 20:15:39
Message-Id: 20100614212025.03685209@mail.a3li.li
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201006-21
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: UnrealIRCd: Multiple vulnerabilities
      Date: June 14, 2010
      Bugs: #260806, #323691
        ID: 201006-21

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities in UnrealIRCd might allow remote attackers to
compromise the "unrealircd" account, or cause a Denial of Service.

Background
==========

UnrealIRCd is an Internet Relay Chat (IRC) daemon.

Affected packages
=================

    -------------------------------------------------------------------
     Package             /   Vulnerable   /                 Unaffected
    -------------------------------------------------------------------
  1  net-irc/unrealircd     < 3.2.8.1-r1                 >= 3.2.8.1-r1

Description
===========

Multiple vulnerabilities have been reported in UnrealIRCd:

* The vendor reported a buffer overflow in the user authorization
  code.

* The vendor reported that the distributed source code of UnrealIRCd
  was compromised and altered to include a system() call that could be
  called with arbitrary user input.

Impact
======

A remote attacker could exploit these vulnerabilities to cause the
execution of arbitrary commands with the privileges of the user running
UnrealIRCd, or a Denial of Service condition. NOTE: By default
UnrealIRCd on Gentoo is run with the privileges of the "unrealircd"
user.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All UnrealIRCd users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-irc/unrealircd-3.2.8.1-r1"

References
==========

  [ 1 ] UnrealIRCd Security Advisory 20090413
        http://www.unrealircd.com/txt/unrealsecadvisory.20090413.txt
  [ 2 ] UnrealIRCd Security Advisory 20100612
        http://www.unrealircd.com/txt/unrealsecadvisory.20100612.txt

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-201006-21.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2010 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature