Gentoo Archives: gentoo-announce

From: Sune Kloppenborg Jeppesen <jaervosz@g.o>
To: gentoo-announce@l.g.o
Cc: bugtraq@×××××××××××××.com, full-disclosure@××××××××××××××.uk, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] [ GLSA 200508-15 ] Apache 2.0: Denial of Service vulnerability
Date: Thu, 25 Aug 2005 05:41:27
Message-Id: 200508250709.48517.jaervosz@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200508-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Apache 2.0: Denial of Service vulnerability
      Date: August 25, 2005
      Bugs: #102991
        ID: 200508-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A bug in Apache may allow a remote attacker to perform a Denial of
Service attack.

Background
==========

The Apache HTTP Server Project is a featureful, freely-available HTTP
(Web) server.

Affected packages
=================

    -------------------------------------------------------------------
     Package         /   Vulnerable   /                     Unaffected
    -------------------------------------------------------------------
  1  net-www/apache      < 2.0.54-r9                      >= 2.0.54-r9
                                                                 < 2.0

Description
===========

Filip Sneppe discovered that Apache improperly handles byterange
requests to CGI scripts.

Impact
======

A remote attacker may access vulnerable scripts in a malicious way,
exhausting all RAM and swap space on the server, resulting in a Denial
of Service of the Apache server.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All apache users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-www/apache-2.0.54-r9"

References
==========

  [ 1 ] ASF Bugzilla Bug 29962
        http://issues.apache.org/bugzilla/show_bug.cgi?id=29962

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200508-15.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0