Gentoo Archives: gentoo-announce

From: Thierry Carrez <koon@g.o>
To: gentoo-announce@l.g.o
Cc: bugtraq@×××××××××××××.com, full-disclosure@××××××××××××××.uk, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] [ GLSA 200508-11 ] Adobe Reader: Buffer Overflow
Date: Fri, 19 Aug 2005 10:45:17
Message-Id: 4305B4E7.2010003@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200508-11
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Adobe Reader: Buffer Overflow
      Date: August 19, 2005
      Bugs: #102730
        ID: 200508-11

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Adobe Reader is vulnerable to a buffer overflow which could potentially
lead to execution of arbitrary code.

Background
==========

Adobe Reader is a utility used to view PDF files.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  app-text/acroread      < 7.0.1.1                       >= 7.0.1.1

Description
===========

A buffer overflow has been reported within a core application plug-in,
which is part of Adobe Reader.

Impact
======

An attacker may create a specially-crafted PDF file, enticing a user to
open it. This could trigger a buffer overflow as the file is being
loaded, resulting in the execution of arbitrary code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Adobe Reader users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-text/acroread-7.0.1.1"

References
==========

  [ 1 ] CAN-2005-2470
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2470
  [ 2 ] Adobe Document 321644
        http://www.adobe.com/support/techdocs/321644.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200508-11.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

Attachments

File name MIME type
signature.asc application/pgp-signature