Gentoo Archives: gentoo-announce

From: Martin Schlemmer <azarah@g.o>
To: gentoo-announce@g.o
Subject: [gentoo-announce] new rc-scripts dependancy
Date: Thu, 15 Nov 2001 17:32:44
Message-Id: 1005867261.1326.8.camel@nosferatu.lan
Hi devs

Baselayout-1.6.6 was just released.  Along with some bugfixes,
updates to scripts, etc, it adds a new dependancy, 'use'.

It basically works the same as the 'need' dependancy, except
that it will only start services that is in the current, and
'boot' runlevels (or only 'boot' if 'boot' is current).

This is primarily for use with rc-scripts that have optional
dependancies, that should only be started when the deps are
actually installed and scheduled to start, for example:

  the netmount script, that should actually have portmap
  as a dependancy, but do not since it will never start
  if the user do not have the nfs tools installed.

Also, it can be used for cases where the dependancy can be
one out of a few, for example:

  postfix have sysklogd as dependancy, but people who uses
  metalog or syslog-ng will have to edit the postfix 
  rc-script, or it will fail to start.

Another place where latter can be used, is with the 'modules'
rc-script (already updated for this).  If you use sysklogd,
and add it to the 'boot' runlevel, and not the 'default' like
in the install guide, bootup will be much cleaner, as sysklogd
sets the console loglevel to 3 (only display errors and up).
Metalog and syslog-ng will have to be updated by developers
who use these two.

Enouth smalltalk.  How it works is as follows (out of postfix):

  depend() {
	need net sysklogd
  }

becomes:

  depend() {
	need net
	use sysklogd metalog syslog-ng
  }

Anyhow, please test, comment and enjoy :)


Greetings,

-- 

Martin Schlemmer
Gentoo Linux Developer, Desktop Team Developer
Cape Town, South Africa