Gentoo Archives: gentoo-announce

From: Tim Sammut <underling@g.o>
To: gentoo-announce@g.o
Cc: bugtraq@×××××××××××××.com, full-disclosure@××××××××××××××.uk, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] [ GLSA 201110-24 ] Squid: Multiple vulnerabilities
Date: Wed, 26 Oct 2011 21:16:44
Message-Id: 4EA876F3.8030604@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201110-24
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: Squid: Multiple vulnerabilities
     Date: October 26, 2011
     Bugs: #279379, #279380, #301828, #334263, #381065, #386215
       ID: 201110-24

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities were found in Squid allowing attackers to
execute arbitrary code or cause a Denial of Service.

Background
==========

Squid is a full-featured web proxy cache.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-proxy/squid              < 3.1.15                  >= 3.1.15

Description
===========

Multiple vulnerabilities have been discovered in Squid. Please review
the CVE identifiers referenced below for details.

Impact
======

Remote unauthenticated attackers may be able to execute arbitrary code
with the privileges of the Squid process or cause a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All squid users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-proxy/squid-3.1.15"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since September 4, 2011. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2009-2621
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-2621
[ 2 ] CVE-2009-2622
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-2622
[ 3 ] CVE-2009-2855
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-2855
[ 4 ] CVE-2010-0308
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-0308
[ 5 ] CVE-2010-0639
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-0639
[ 6 ] CVE-2010-2951
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-2951
[ 7 ] CVE-2010-3072
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-3072
[ 8 ] CVE-2011-3205
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3205

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201110-24.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature