Gentoo Archives: gentoo-announce

From: Sean Amoss <ackle@g.o>
To: gentoo-announce@g.o
Subject: [gentoo-announce] [ GLSA 201203-06 ] sudo: Privilege escalation
Date: Tue, 06 Mar 2012 03:41:59
Message-Id: 4F557061.7090106@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201203-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: sudo: Privilege escalation
     Date: March 06, 2012
     Bugs: #351490, #401533
       ID: 201203-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Two vulnerabilities have been discovered in sudo, allowing local
attackers to possibly gain escalated privileges.

Background
==========

sudo allows a system administrator to give users the ability to run
commands as other users.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  app-admin/sudo              < 1.8.3_p2               >= 1.8.3_p2
                                                         *>= 1.7.4_p5

Description
===========

Two vulnerabilities have been discovered in sudo:

* When the sudoers file is configured with a Runas group, sudo does not
  prompt for a password when changing to the new group (CVE-2011-0010).
* A format string vulnerability exists in the "sudo_debug()" function
  (CVE-2012-0809).

Impact
======

A local attacker could possibly gain the ability to run arbitrary
commands with the privileges of other users or groups, including root.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All sudo users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-admin/sudo-1.8.3_p2"

References
==========

[ 1 ] CVE-2011-0010
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-0010
[ 2 ] CVE-2012-0809
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0809

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201203-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature