Gentoo Archives: gentoo-announce

From: Sean Amoss <ackle@g.o>
To: gentoo-announce@g.o
Subject: [gentoo-announce] [ GLSA 201203-23 ] libzip: Multiple vulnerabilities
Date: Thu, 29 Mar 2012 11:50:48
Message-Id: 4F744AA8.8010500@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201203-23
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: libzip: Multiple vulnerabilities
     Date: March 29, 2012
     Bugs: #409117
       ID: 201203-23

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in libzip, the worst of which
might allow execution of arbitrary code.

Background
==========

libzip is a library for manipulating zip archives.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-libs/libzip              < 0.10.1                  >= 0.10.1

Description
===========

Two vulnerabilities have been found in the "_zip_readcdir()" function
in zip_open.c of libzip:

* An incorrect loop construct, which could cause a heap-based buffer
  overflow (CVE-2012-1162).
* An integer overflow, which may not restrict operations within the
  memory buffer (CVE-2012-1163).

Impact
======

A remote attacker could entice a user to open a specially crafted ZIP
file, possibly resulting in execution of arbitrary code with the
privileges of the process, a Denial of Service condition, or
information leaks.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libzip users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/libzip-0.10.1"

References
==========

[ 1 ] CVE-2012-1162
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1162
[ 2 ] CVE-2012-1163
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1163

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201203-23.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature