Gentoo Archives: gentoo-announce

From: Alex Legler <a3li@g.o>
To: gentoo-announce@l.g.o
Cc: bugtraq@×××××××××××××.com, full-disclosure@××××××××××××××.uk, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] [ GLSA 201111-10 ] Evince: Multiple vulnerabilities
Date: Sun, 20 Nov 2011 18:29:54
Message-Id: 201111201914.25918.a3li@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201111-10
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Evince: Multiple vulnerabilities
     Date: November 20, 2011
     Bugs: #350681, #363447
       ID: 201111-10

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Evince, allowing remote
attackers to execute arbitrary code or cause a Denial of Service.

Background
==========

Evince is a document viewer for multiple document formats, including
PostScript.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  app-text/evince            < 2.32.0-r2              >= 2.32.0-r2 

Description
===========

Multiple vulnerabilities have been discovered in Evince. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could entice a user to load a DVI file with a
specially crafted font, resulting in the execution of arbitrary code
with the privileges of the user running the application or a Denial of
Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Evince users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-text/evince-2.32.0-r2"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since April 26, 2011. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2010-2640
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-2640
[ 2 ] CVE-2010-2641
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-2641
[ 3 ] CVE-2010-2642
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-2642
[ 4 ] CVE-2010-2643
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-2643

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201111-10.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature